Closed Bug 989767 Opened 6 years ago Closed 6 years ago

When the tabbar is hidden (popup), the top border of the location bar is gone

Categories

(Firefox :: Theme, defect)

29 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 --- wontfix
firefox30 --- affected
firefox31 --- verified

People

(Reporter: henry.fai.hang.chan, Assigned: jaws)

References

Details

(Whiteboard: [Australis:P4] p=0 s=it-31c-30a-29b.3 [qa!])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140329030204

Steps to reproduce:

This is a regression with Australis.

Open a popup with toolbar=0.
The top border is gone.
This is due to chrome://browser/skin/browser.css Line 268.

> #nav-bar {
>  background-image: linear-gradient(rgba(253,253,253,0.45), rgba(255,255,255,0));
>  box-shadow: 0 1px 0 rgba(253,253,253,0.45) inset;
>  margin-top: -1px; /* Move up 1px into the TabsToolbar */


Patch
+#TabsToolbar:not([collapsed="true"]) + #nav-bar {
+    margin-top:-1px; /* Move up 1px into the TabsToolbar */
+}
 #nav-bar {
     background-image: linear-gradient(rgba(253,253,253,0.45), rgba(255,255,255,0));
     box-shadow: 0 1px 0 rgba(253,253,253,0.45) inset;
-    margin-top: -1px; /* Move up 1px into the TabsToolbar */
Component: Untriaged → General
Actually, shouldn't the negative margin be set on the tabbar instead of the navigation toolbar? This alternative approach avoids all the CSS **** in adding an additional margin or padding to items who protruded into the border...
I don't clearly understand your issue. Can you provide a screenshot and some step to reproduce ? Thanks :)
Ok, I now understand your issue.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: General → Theme
Flags: firefox-backlog+
Thanks for reporting. I have confirmed the issue.
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Whiteboard: [Australis:P4]
Attached patch PatchSplinter Review
I tested this on Windows. Do you think you could run it through your screenshot tool? I also moved the position:relative; and z-index:1; rules since they are only needed when the TabsToolbar is showing.
Attachment #8409520 - Flags: review?(MattN+bmo)
Attachment #8409520 - Flags: review?(MattN+bmo) → review+
OS: Windows 7 → All
Hardware: x86 → All
Version: Trunk → 29 Branch
https://hg.mozilla.org/mozilla-central/rev/7ede33d15218
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P4][fixed-in-fx-team] → [Australis:P4]
Target Milestone: --- → Firefox 31
Whiteboard: [Australis:P4] → [Australis:P4] p=0 s=it-31c-30a-29b.3 [qa?]
QA Contact: florin.mezei
Whiteboard: [Australis:P4] p=0 s=it-31c-30a-29b.3 [qa?] → [Australis:P4] p=0 s=it-31c-30a-29b.3 [qa+]
QA Contact: florin.mezei → cornel.ionce
This issue is verified fixed on Nightly 31 2014-04-24 (Build ID: 20140424030204) using:
- Windows 7 64-bit [1],
- Windows 8.1 Pro 64-bit (Microsoft Surface Pro 2) [2],
- Ubuntu 14.04 LTS 32-bit [3],
- Mac OS X 10.9 [4].

1. Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:31.0) Gecko/20100101 Firefox/31.0
2. Mozilla/5.0 (Windows NT 6.3; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
3. Mozilla/5.0 (X11; Linux i686; rv:31.0) Gecko/20100101 Firefox/31.0
4. Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Firefox/31.0
Status: RESOLVED → VERIFIED
Whiteboard: [Australis:P4] p=0 s=it-31c-30a-29b.3 [qa+] → [Australis:P4] p=0 s=it-31c-30a-29b.3 [qa!]
https://groups.google.com/forum/#!topic/mozilla.dev.tree-management/idqLnBoyBsM

I suspect this is related. Jared, can you look into this?
Flags: needinfo?(jaws)
I don't see anything in the patch that would cause a regression, besides the style system having to do a tiny amount more of work by using the adjacent sibling selector.
Flags: needinfo?(jaws)
You need to log in before you can comment on or make changes to this bug.