Closed Bug 989845 Opened 6 years ago Closed 6 years ago

[Bluetooth][PTS][Bluedroid][1.4] HSP__TC_AG_ACR_BV_01_I Failed

Categories

(Firefox OS Graveyard :: Bluetooth, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.4+, firefox29 wontfix, firefox30 fixed, firefox31 fixed, b2g-v1.4 fixed, b2g-v2.0 fixed)

VERIFIED FIXED
1.4 S5 (11apr)
blocking-b2g 1.4+
Tracking Status
firefox29 --- wontfix
firefox30 --- fixed
firefox31 --- fixed
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: echang, Assigned: ben.tian)

References

Details

Attachments

(2 files)

### ENV
Nexus 4/Bluesdroid 
[1] https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-aurora-nexus-4/2014/03/2014-03-25-16-02-01/

### STR
1. PTS 5.0
2. HSP__TC_AG_ACR_BV_01_I

### Expected
Pass 

### Actual
The IUT is not in call, still ringing but the PTS asks to verify the presence of voice..
Blocks: 986297
Bluedroid connects SCO automatically but doesn't call AnswerCallCallback, so HFP manager doesn't notify dialer to answer call. Need to check bluedroid code for detailed flow.
Assignee: nobody → btian
Comment on attachment 8402476 [details] [diff] [review]
Patch 1 (v1): Implement KeyPressedCallback to handle HSP commands

Implement KeyPressedCallback on bluedroid to handle HSP commands.
Attachment #8402476 - Flags: review?(echou)
Attachment #8402476 - Attachment description: WIP patch → Patch 1 (v1): Implement KeyPressedCallback to handle HSP commands
Duplicate of this bug: 989846
Comment on attachment 8402476 [details] [diff] [review]
Patch 1 (v1): Implement KeyPressedCallback to handle HSP commands

Review of attachment 8402476 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks. :)
Attachment #8402476 - Flags: review?(echou) → review+
Set 1.4? since this bug fails 1.4 bluetooth certification HSP test case TC_AG_ACR_BV_01_I.
blocking-b2g: --- → 1.4?
Certification blocker = 1.4+
blocking-b2g: 1.4? → 1.4+
https://hg.mozilla.org/mozilla-central/rev/b9895430b3da
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.