query page uses non-standard and ambiguous date field

RESOLVED WORKSFORME

Status

()

Bugzilla
Query/Bug List
P2
normal
RESOLVED WORKSFORME
17 years ago
6 years ago

People

(Reporter: James Green, Assigned: Nobody's working on this, feel free to take it)

Tracking

Details

(Reporter)

Description

17 years ago
A text field exists to enter a date in. No help is given to indicate what format
that date should be entered as. It could be one or more of a number of ways. It
needs to be standardised to the ISO standard YYYY-MM-DD and this should be shown
on the page itself.

From what we in #mozillazine can tell, Month D, Y works and so does MM/DD/YY,
neither of which are international standards.

Comment 1

17 years ago
It took a long good while before I got my date query to work.

Naturally, the first thing I tried was to enter the YYYY-MM-DD format, as it is 
the most usual one I know of.

Then I had to trial-and-error the MM/DD/YY, DD/MM/YY etc. formats for a while 
before I got it to work. :(
Moving to new Bugzilla product ...
Assignee: justdave → endico
Component: Bugzilla → Query/Bug List
Priority: -- → P2
Product: Webtools → Bugzilla
Target Milestone: --- → Bugzilla 2.16
Version: other → unspecified
We are currently trying to wrap up Bugzilla 2.16.  We are now close enough to
release time that anything that wasn't already ranked at P1 isn't going to make
the cut.  Thus this is being retargetted at 2.18.  If you strongly disagree with
this retargetting, please comment, however, be aware that we only have about 2
weeks left to review and test anything at this point, and we intend to devote
this time to the remaining bugs that were designated as release blockers.
Target Milestone: Bugzilla 2.16 → Bugzilla 2.18

Comment 4

17 years ago
I agree that the default date format should be ISO 8601.

The date shown for 'Opened' is 
correct, yet the date shown for attachments is MM/DD/YY.  All dates should be displayed in the same 
format at the very least.
Assignee: endico → nobody

Comment 5

14 years ago
These bugs appear to be abandoned.  Retargeting to 2.20
Target Milestone: Bugzilla 2.18 → Bugzilla 2.20

Comment 6

13 years ago
*** Bug 114402 has been marked as a duplicate of this bug. ***

Comment 7

13 years ago
Seems to be fixed for a long time now. All dates have the YYYY-MM-DD format, see
bug 21145, bug 30259 and bug 93037 for example. Marking WFM.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
clearing target of DUPLICATE/WONTFIX/INVALID/WORKSFORME so they'll show up as
untriaged if they get reopened.
Target Milestone: Bugzilla 2.20 → ---
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.