If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Move "Edit Link in Composer" option from right click menu lower

VERIFIED DUPLICATE of bug 75338

Status

SeaMonkey
General
--
trivial
VERIFIED DUPLICATE of bug 75338
16 years ago
13 years ago

People

(Reporter: Sakari Lehtonen, Assigned: Bradley Hart)

Tracking

({polish})

Trunk
x86
Linux
polish

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.3+) Gecko/20010907
BuildID:    2001090712

When right clicking on a link, I usually select the first option
"Open in New Window". When doing this frequently, I have chosen
"Edit Link in Composer" many times. This is annoying. 

I don't see any reason why I would like to edit pages so 
frequently that the option has to be second in the menu.

It would be nice if the option would be moved down in the menu to a different
position, so that "Open in new Window" would remain 
alone as the first option (in it's own group, no items between it and the next
separator). 
 
I know this happens only when you do this by habit, and is only my
own opinion. But I think that opening pages in new windows and editing pages
have little to do with each other.
 



Reproducible: Sometimes
Steps to Reproduce:
1. Choose a link, any link.
2. Press the right button on the link
3. Move the mouse down a little and press the
   left button. Do this so that you don't even look at the menu.
4. Wait for the menu to appear


Actual Results:  If you move down too much, you end up in Composer editing the page.

Expected Results:  Open the window in a new link.

Comment 1

16 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: polish, ui
(Assignee)

Comment 2

16 years ago
I like this idea, hitting the "edit in composer" item is annoying.

But where should this menuitem go? I was thinking just above "view page source",
as this would seem to make the most sense...
Assignee: mpt → bhart00

Comment 3

16 years ago
Now in Moz 0.9.5 the logical decision would be to put "Open in New Window" and
"Open in New Tab" on the first positions. After them the separator, and we could
move "Edit Link in Composer" just under "Save Link As..." for example.
(Assignee)

Comment 4

16 years ago
This is covered in bug 75338.

*** This bug has been marked as a duplicate of 75338 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
vrfy dupe
Status: RESOLVED → VERIFIED

Updated

15 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.