Closed Bug 990310 Opened 6 years ago Closed 6 years ago

Remove SurfaceDescriptor from media

Categories

(Core :: WebRTC, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla31

People

(Reporter: sotaro, Assigned: sotaro)

References

(Blocks 1 open bug)

Details

Attachments

(4 files, 3 obsolete files)

SurfaceDescriptor usage should be limited only to IPC handling class.
Mike - is this something for you?
Flags: needinfo?(mhabicher)
No, this is Sotaro's speciality.
Flags: needinfo?(mhabicher)
I take this bug.
Assignee: nobody → sotaro.ikeda.g
Duplicate of this bug: 990309
Summary: Remove SurfaceDescriptor from MediaEngineWebRTCVideo.cpp → Remove SurfaceDescriptor from media
Fix nits.
Attachment #8402919 - Attachment is obsolete: true
Attachment #8402923 - Attachment is obsolete: true
Fix GrallocImage::GetGraphicBuffer().
Attachment #8403389 - Attachment is obsolete: true
Attachment #8403510 - Flags: review?(nical.bugzilla)
Attachment #8403510 - Flags: review?(nical.bugzilla) → review+
Attachment #8403397 - Flags: review?(cajbir.bugzilla)
Attachment #8403392 - Flags: review?(rjesup)
Attachment #8403397 - Flags: review?(cajbir.bugzilla) → review+
Comment on attachment 8403392 [details] [diff] [review]
patch part 2 - Change around webrtc

Review of attachment 8403392 [details] [diff] [review]:
-----------------------------------------------------------------

I'm afraid I know nothing of those API calls, which were added by the B2G/Camera folk.

Also, this may be moot due to bug 991028 which already changed some or all of this code
Attachment #8403392 - Flags: review?(rjesup)
Attachment #8403392 - Flags: review?(nical.bugzilla)
Attachment #8403392 - Flags: review?(nical.bugzilla) → review+
Attached patch rollup patachSplinter Review
roll up and un-bitrot.
Attachment #8404750 - Flags: review+
Attachment #8404750 - Attachment is patch: true
Attachment #8404750 - Attachment mime type: text/x-patch → text/plain
https://hg.mozilla.org/mozilla-central/rev/dac05f94472a
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
You need to log in before you can comment on or make changes to this bug.