justask.org.uk - Bug 22274 shows up

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English Other
P3
normal
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: hsivonen, Assigned: Tristan Nitot)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
Build ID: 2001090821

The page http://www.justask.org.uk/ has an XHTML doctype declaration and,
therefore, is displayed in the standards mode. However, they use sliced images
in tables without taking bug 22274 into account.

The problem can be dealt with in the standards mode
(http://www.hut.fi/u/hsivonen/standards#img-display-block) or by switching to
the quirks mode.

Comment 1

17 years ago
Moving to new component "West Europe".  European component is being removed. 
See bug 95808 for details.
Component: European → West Europe
QA Contact: momoi → caillon
(Assignee)

Comment 2

16 years ago
Contact : webadmin@justask.org.uk

Henri, I don't get it. The bug 22274 is now verified invalid. Is the problem on
our side then ?

Please advice.

Confirming. Accepting bug. Setting P3.
Status: NEW → ASSIGNED
Priority: -- → P3
(Reporter)

Comment 3

16 years ago
Bug 22274 has been marked INVALID, because as per the CSS2 spec there is no bug.
However, the CSS2 spec doesn't match author expectations in this case.

<img> is an inline element. Even when a lone image appears in a table cell,
Mozilla generates a line box in the standards mode. This yields results that the
authors aren't expecting. The problem can be worked around by changin the
display property of the <img> element and the possible enclosing <a> element to
block.

http://www.hut.fi/u/hsivonen/standards#lineboxmodel
http://www.mozilla.org/docs/web-developer/faq.html#gaps

Opera and IE don't generate the line box when a table cell (or a block in
general) only contains an image (possibly wapped in an <a>). Mozilla works like
IE and Opera in the quirks mode.

dbaron and Hixie have been against following the behavior of IE and Opera in the
standards mode. The problem is that virtually no author wants or needs Mozilla's
current line box generation behavior in table cells. Many authors shy away from
the standards mode because of bug 22274 and get a whole bunch of old quirks when
they only need a "fix" for bug 22274.

If bug 22274 didn't exist, the barrier for moving to the standards mode would be
significantly lower for a number of authors.

See also bug 78208.

(BTW, making XHTML 1.0 Transitional and HTML 4.01 Transitional docs render in
the quirks mode *is not* the solution. It would just be mean unwilligness to
address the real issue (bug 22274). Also, it would be a problem for authors who
don't want quirks in new browsers but need to use deprecated markup in order to
achieve graceful degradation. However, "fixing" bug 22274 specifically for those
docs would help.)

From the evang point of view, all this is indeed quite hard to explain. As long
as bug 22274 persists, there are two ways around it:
* Using the quirks mode (It is quite silly from the evang point of view to ask
people to use the quirks mode.)
* using display: block;

Comment 4

16 years ago
page looks WFM and all bugs mentioned here are closed/fixed.
can anyone verify ?
(Reporter)

Comment 5

16 years ago
The site has applied a fix.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 6

15 years ago
tech evang june 2003 reorg
Component: Europe: West → English Other
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.