Closed Bug 990365 Opened 6 years ago Closed 6 years ago

[tarako] two "<div id="homescreen"...></div> in System app after running monkey test

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: jj.evelyn, Unassigned)

References

Details

Attachments

(2 files)

see bug 988110 comment 28. After running monkey test, there are two "<div id="homescreen"...></div>". The second one is empty, and is on top of the first one.
See Also: → 988110
blocking-b2g: --- → 1.3T?
Status update: we are trying to reproduce this issue.
minus for now until we have actionable information
blocking-b2g: 1.3T? → -
Alive, may I know your patch in bug 988110 will fix the problem here?
It seems the ensure() is called many times, and may be it happens in a very short period before a ensure() call return. Is it possible that multiple homescreen div are injected in this scenario?
Flags: needinfo?(alive)
I am not sure. There shouldn't be only one div left...
I still need some log in appendChild() and removeChild() calls.
Flags: needinfo?(alive)
Need info myself to insert more log in appendChild() and removeChild() in homescreen_window
Flags: needinfo?(tzhuang)
Duplicate of this bug: 990435
I add some log around appendChild() and removeChild() of this.element in homescreen_window

https://github.com/dwi2/gaia/tree/bug990365_printlog

I also add some log before and after we insert <div id="homescreen"> into DOM.

Hi Yang Zhao,
Please help to integrate the patch https://github.com/dwi2/gaia/tree/bug990365_printlog and run with monkey test to see if we can get more detail information. 
Thanks
Flags: needinfo?(tzhuang) → needinfo?(yang.zhao)
James has merged this WIP patch to our hudson build.
Flags: needinfo?(yang.zhao)
blocking-b2g: - → 1.3T?
what's the reason for 1.3T? can you please provide some comments? do you mean the patch work? thanks
Flags: needinfo?(james.zhang)
(In reply to Joe Cheng [:jcheng] from comment #9)
> what's the reason for 1.3T? can you please provide some comments? do you
> mean the patch work? thanks

Loop Yang.Zhao, is this bug fixed?
It cause homescreen icon overlap and it's spreadtrum major bug.
Flags: needinfo?(james.zhang) → needinfo?(yang.zhao)
(In reply to James Zhang from comment #10)
> (In reply to Joe Cheng [:jcheng] from comment #9)
> > what's the reason for 1.3T? can you please provide some comments? do you
> > mean the patch work? thanks
> 
> Loop Yang.Zhao, is this bug fixed?
> It cause homescreen icon overlap and it's spreadtrum major bug.
What you said is another bug 990435 .
This bug is about after runnning monkey test,the phone sometimes stays on homescreen which has no response. From the nightly ,you can see the cause is two "<div id=homescreen> ...</div>" in system app.
Flags: needinfo?(yang.zhao)
(In reply to Joe Cheng [:jcheng] from comment #9)
> what's the reason for 1.3T? can you please provide some comments? do you
> mean the patch work? thanks

The issue causes the homescreen no response,and it occurs after running monkey test.With Alive's patch in bug 988110 ,this issue doesn't reproduce till now.I don't know whether it's the patch worked.See comment #3 and comment #4
Keep monitoring.
Whiteboard: [MP_Blocker]
triage; partner blocker 1.3T+
ni? Alive
blocking-b2g: 1.3T? → 1.3T+
Flags: needinfo?(alive)
Whiteboard: [MP_Blocker] → [priority]
triage: partner is hardly seeing this anymore, minus for now
blocking-b2g: 1.3T+ → -
Whiteboard: [priority]
Flags: needinfo?(alive)
Per comment 12 and we can't reproduce this issue by our monkeys, close it as worksforme.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
I can still meet this bug when monkey test.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
sorry, steven will ask peipei file a new bug.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → WORKSFORME
(In reply to James Zhang from comment #17)
> I can still meet this bug when monkey test.

James,what you meet is another bug 990435 ,not this one.
(In reply to yang.zhao from comment #19)
> (In reply to James Zhang from comment #17)
> > I can still meet this bug when monkey test.
> 
> James,what you meet is another bug 990435 ,not this one.

Ignore the comment,I am misunderstanding.
I met this after 12 hours of monkey test,when I press the HOME button ,I saw the following logs were printed out:
E/GeckoConsole( 3937): [JavaScript Error: "TypeError: app is undefined" {file: "app://system.gaiamobile.org/js/window_manager.js" line: 470}]

There were also two homescreen div,the attachment is the log.
Attached file another phone log
This is another phone log after running monkeytest.The Inspector of nightly shows nothing,so I don't know whether this is two div,but the phone's homescreen also has no response ,but you can unlock the phone or enter the camera normally from the lockscreen.
hi,Tzh-Lin
   Could you help to see the log ?
Flags: needinfo?(tzhuang)
Hi Yang,

(In reply to yang.zhao from comment #21)
> Created attachment 8406566 [details]
> log of  two div after monkey test
> 
> I met this after 12 hours of monkey test,when I press the HOME button ,I saw
> the following logs were printed out:
> E/GeckoConsole( 3937): [JavaScript Error: "TypeError: app is undefined"
> {file: "app://system.gaiamobile.org/js/window_manager.js" line: 470}]
> 
> There were also two homescreen div,the attachment is the log.

I'm checking the log.

Do you have screenshot of DOM structure of two homescreen div?
Because we have the same symptom here after 18 hours of monkey test, but we were unable to check DOM structure by app-manager. 
So it might be too early to conclude that was two homescreen div.
Flags: needinfo?(yang.zhao)
(In reply to Tzu-Lin Huang [:dwi2][:tzhuang] from comment #24)
> Hi Yang,
> 
> (In reply to yang.zhao from comment #21)
> > Created attachment 8406566 [details]
> > log of  two div after monkey test
> > 
> > I met this after 12 hours of monkey test,when I press the HOME button ,I saw
> > the following logs were printed out:
> > E/GeckoConsole( 3937): [JavaScript Error: "TypeError: app is undefined"
> > {file: "app://system.gaiamobile.org/js/window_manager.js" line: 470}]
> > 
> > There were also two homescreen div,the attachment is the log.
> 
> I'm checking the log.
> 
> Do you have screenshot of DOM structure of two homescreen div?
> Because we have the same symptom here after 18 hours of monkey test, but we
> were unable to check DOM structure by app-manager. 
> So it might be too early to conclude that was two homescreen div.


I attach two attachments in comment#21 and comment#22 :comment#21 is two div ,I could see it from app-manager,but comment#22 is the same with what you said .
Flags: needinfo?(yang.zhao)
hi,Tzu-Lin
   The phone I mentioned in commment#22 couldn't be seen in app-manager,but you can use the Console to find out that if there are two div,you could also set the empty div's display to none,and the phone will work. 
    I enter the sentences like the followings:
    a = document.getElementById('homescreen')
    a.nextSibling.id
    a.nextSibling.style.height
    a.nextSibling.style.display="none"
blocking-b2g: - → 1.3T?
(In reply to James Zhang from comment #18)
> sorry, steven will ask peipei file a new bug.

@James/Yang, I filed bug https://bugzilla.mozilla.org/show_bug.cgi?id=996514.
let's trace it at bug 996514, since it was closed and the symptom was different
Flags: needinfo?(tzhuang)
blocking-b2g: 1.3T? → ---
You need to log in before you can comment on or make changes to this bug.