Closed Bug 990473 Opened 7 years ago Closed 6 years ago

missing next button in <input type='number' >

Categories

(Firefox for Android :: Keyboards and IME, defect)

28 Branch
All
Android
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 33
Tracking Status
firefox28 --- affected
firefox29 --- affected
firefox30 --- affected
firefox31 --- affected

People

(Reporter: gillesseerden, Assigned: jchen)

Details

Attachments

(2 files)

Attached image Screenshot_firefox.png
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.154 Safari/537.36

Steps to reproduce:

Simple html form with <input type="number">. 

https://support.mozilla.org/en-US/questions/991970


Actual results:

On a nexus 7, the virtual keyboard does not display a "next" button as it does with <input type="text">


Expected results:

On a nexus 7, the virtual keyboard does display a "next" button in Chrome, Mobile Safari.
OS: Windows XP → Android
Hardware: x86 → All
Assignee: nobody → nchen
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
A "number" input contains anonymous child nodes including the number field and the up/down spinner. If the focus is in the anonymous subtree, we should check the top-level input (i.e. the binding parent) for the action hint.
Attachment #8456433 - Flags: review?(masayuki)
Comment on attachment 8456433 [details] [diff] [review]
Check parent input for action hint if focus is in anonymous subtree (v1)

LGTM. But I'm not sure if this works fine with XUL element.

Smaug, do you have some idea about this?
Attachment #8456433 - Flags: review?(masayuki)
Attachment #8456433 - Flags: review?(bugs)
Attachment #8456433 - Flags: review+
Comment on attachment 8456433 [details] [diff] [review]
Check parent input for action hint if focus is in anonymous subtree (v1)

>+    nsIContent* inputContent = aContent->IsInAnonymousSubtree() ?
>+                               aContent->GetBindingParent() : aContent;
>+
You could do
nsIContent* inputContent = aContent->FindFirstNonChromeOnlyAccessContent()
That would be even more correct, since IsInAnonymousSubtree deals with non-native anonymous content too.
Attachment #8456433 - Flags: review?(bugs) → review+
Made the change to FindFirstNonChromeOnlyAccessContent().

https://hg.mozilla.org/integration/mozilla-inbound/rev/4571dc040857
https://hg.mozilla.org/mozilla-central/rev/4571dc040857
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
You need to log in before you can comment on or make changes to this bug.