Firefox 29 lacks addon status bar and a lot of addons like Domain Details (IP, server headers) uses only addon bar

RESOLVED DUPLICATE of bug 890008

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 890008
5 years ago
5 years ago

People

(Reporter: nix.sasl, Unassigned)

Tracking

29 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140327113732

Steps to reproduce:

Firefox 29 lacks addon status bar and a lot of addons like Domain Details (IP, server headers) uses only addon bar.

No other addon have: IP, Country Flag, Server Headers in the same icon.

So, is not 100% true that all icons was moved to navigation bar.

I suggest that the addon bar are optional, like a addon or in preferences, enable or disable, but not remove it.


Actual results:

A lot of addons does not work because addon bar was removed, in 28 is optional


Expected results:

Recover addons, Domain Details and others.
Severity: normal → major
Blocks: 749804
Status: UNCONFIRMED → NEW
Component: Untriaged → Toolbars and Customization
Ever confirmed: true
Some progress with this bug?
This is very unlikely to be addressed. There are add-ons already bring back the add-on bar and the status-bar: The Puzzle Piece (use latest 1.3.x still to be reviewed) or Classic Theme Restorer are good bets.
(In reply to Luís Miguel [:Quicksaver] from comment #2)
> This is very unlikely to be addressed. There are add-ons already bring back
> the add-on bar and the status-bar: The Puzzle Piece (use latest 1.3.x still
> to be reviewed) or Classic Theme Restorer are good bets.

All addons for it, adds more memory and cpu usage to Firefox.
There is also https://addons.mozilla.org/en-US/firefox/addon/new-add-on-bar/ which just adds the add-on bar back. 

(In reply to Nix\ from comment #3)
> All addons for it, adds more memory and cpu usage to Firefox.

The overhead for an extension like this is small compared to Firefox as a whole. The Domain Details extensions could also create the add-on bar if it doesn't already exist.

We don't have any plans to add the add-on bar back. Install one of the many extensions if you are a user who requires it. You should contact the Domain Details extension author if the extension doesn't work in other toolbars.
Status: NEW → RESOLVED
Closed: 5 years ago
OS: Linux → All
Hardware: x86 → All
Resolution: --- → DUPLICATE
Duplicate of bug: 890008
You need to log in before you can comment on or make changes to this bug.