Closed Bug 990512 Opened 6 years ago Closed 5 years ago

Switching tabs with keyboard-shortcuts is not working in about:config while an option is selected

Categories

(Core :: User events and focus handling, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1008772

People

(Reporter: elbart, Unassigned)

Details

STR:
- Open the browser and open a new tab, two or more tabs need to be open.
- Go to about:config and click away the warning.
- Scroll the richlist down a bit and select any option, so it's highlighted.
- Press Ctrl+PageUp or Ctrl+PageDown to switch to any other tab.

ER:
The browser switches to a different tab.

AR:
The richlist is being scrolled up or down depending on Ctrl+PgUp or Ctrl+PgDown being used.

Note:
The lack of tab-switching is also happening when any element (button, checkbox, menulist-button, texteditbox) has the focus in an in-content-option-area of an addon in about:addon, i.e. New Tab Tools or RAM Restart.

Regression range:
m-c
Last good revision: d812f80a0f1d (2014-02-11)
First bad revision: 802d87c77e76 (2014-02-12)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d812f80a0f1d&tochange=802d87c77e76

m-i
Last good revision: 9ce7c3a70c13
First bad revision: b724cd142b51
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9ce7c3a70c13&tochange=b724cd142b51

Suspect:
bug 950373
> has the focus in an in-content-option-area of an 
> addon in about:addon, i.e. New Tab Tools or RAM Restart.
Oops, it's actually about:addons.

And the URLs for the mentioned addon-examples are
https://addons.mozilla.org/en-US/firefox/addon/new-tab-tools/
https://addons.mozilla.org/en-US/firefox/addon/ram-restart/
Blocks: 950373
Thank you.
Confirmed in 31.0a1 (2014-04-01), win 7 x64.
Status: UNCONFIRMED → NEW
Ever confirmed: true
It's sad.
Status: NEW → RESOLVED
Closed: 5 years ago
Depends on: 1008772
Resolution: --- → WORKSFORME
No longer blocks: 950373
No longer depends on: 1008772
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1008772
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.