Crash while loading/displaying Crash Analysis page [@ nsCSSFrameConstructor::AttributeChanged]

VERIFIED WORKSFORME

Status

()

Core
CSS Parsing and Computation
--
critical
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Oliver Klee, Assigned: dbaron)

Tracking

({crash, topcrash})

Trunk
x86
Windows 2000
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.3+)
Gecko/20010910
BuildID:    2001091003

Loading/displaying the Crash Analysis page crashes Mozilla (no pun intended).

Reproducible: Always
Steps to Reproduce:
1. visit ftp://ftp.mozilla.org/pub/data/crash-data/detailed-crash-analysis-all.html

Actual Results:  Crash

Expected Results:  No crash

Talkback IDs 34927979, 34946595, 34927979, 34946595, 34949678, 34919922, 34950856
(Reporter)

Updated

17 years ago
Keywords: crash, mozilla0.9.4, mozilla0.9.5, nsbranch, topcrash
(Assignee)

Comment 1

17 years ago
Hrm.  The first 4 talkback reports point to bug 97770, the next two are garbage,
and the last one is

0x00000000
0x0575e0bc
0x00080014
0x04034b08
gkcontent.dll + 0xf64d8 (0x602e64d8)
nsHTMLDocument::AddRef
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLDocument.cpp, line 288]
nsHTMLDocument::AttributeWillChange
[d:\builds\seamonkey\mozilla\content\html\document\src\nsHTMLDocument.cpp, line
1223]
0xec1d8b53 

What makes you think the crashes are at nsCSSFrameConstructor::AttributeChanged?
(Reporter)

Comment 2

17 years ago
I had looked for the URL in the Crash analysis page. Talkback 34950856 has
nsCSSFrameConstructor::AttributeChanged on top of the stack just after
0x00000000. But maybe I'm just misreading that page ... the number after "BBID:"
is the Talkback ID, isn't it? If not, how can I find out the Talkback IDs and
the stacktraces for crashes with a certain URL?

Comment 3

17 years ago
David - This looks like a very good candidate to take. How close are we to
resolving this one?

Comment 4

17 years ago
This is a topcrash. Nominating for nsbranch+.
Keywords: nsbranch → nsbranch+
(Assignee)

Comment 5

17 years ago
No, the stack associated with the report is the one above it.  The stack trace
is the first thing listed in each entry.
(Reporter)

Comment 6

17 years ago
This is not crashing for me anymore on 2001091403 Win2k. Marking WFM.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 7

17 years ago
mark verified.
Using 2001-09-24-05-094 branch build, no longer crashes.
Oliver - you verified on the trunk, right?
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

17 years ago
Yes, I was using a 2001091403 trunk build.
Crash Signature: [@ nsCSSFrameConstructor::AttributeChanged]
You need to log in before you can comment on or make changes to this bug.