Crash on this secure page

RESOLVED DUPLICATE of bug 99052

Status

NSS
Libraries
--
critical
RESOLVED DUPLICATE of bug 99052
17 years ago
17 years ago

People

(Reporter: brentmh, Assigned: Nelson Bolyard (seldom reads bugmail))

Tracking

({crash, regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
I am seeing this crash on both the trunk and the 0.9.4 branch.  This must be a
regression since it didn't occur with 0.9.3

Comment 1

17 years ago
Reporter, could you post a talkback ID and your build ID?

Please read the bug reporting guidelines at
http://www.mozilla.org/quality/bug-writing-guidelines.html and consider using
Bugzilla Helper at http://www.mozilla.org/quality/help/bugzilla-helper.html to
report bugs. Thanks for using Mozilla!
Keywords: crash, regression
(Reporter)

Comment 2

17 years ago
Sorry, here is some more information:

The bug only occurs for me in Linux.  Today's windows 0.9.4 branch builds seem
to work fine.  The page has an "invalid" certificate, so the windows build pops
up a dialog informing me of this fact and asking if I still want to accept it.  
This is the correct behaviour.

On Linux the crash bug appears to be 100% reproducible.  No matter I go to the
page (type id URL, or enter bookmark) it crashes.  It does not popup any sort of
dialog.  For the 0.9.4 branch I used buildID 2001091005 from mozilla.org and for
the trunk I used a my own build with buildID 2001091003.

Comment 3

17 years ago
wfm 2001091001 linux
(Reporter)

Comment 4

17 years ago
OK, I tried deleting my .mozilla directory and now it works for me as well. 
After a bit more poking I narrowed it down to the file cert7.db.  I had visited
this site with an earlier version of mozilla and asked it to remember the
certificate.  

Did the structure of this file change?  Is mozilla perhaps just not gracefully
handling the old format?

Comment 5

17 years ago
WFM Win98SE build 2001091003
WFM Linux 2001091001
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 6

17 years ago
Sorry, should have been marked WFM

Comment 7

17 years ago
.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 8

17 years ago
Marking wfm per reporters comment
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 9

17 years ago
This bug should probably be reopened:

It only crashes in subsequent browser sessions; you have to click "Remember this
certificate permanently" when prompted to approve it, then quit mozilla, start a
new browser and go back to the same site; only then will it crash.

Removing the cert makes it not crash again until after you choose to remember
the cert again. Mozilla.rv:0.9.3+.2001090521 works but none later. Currently I'm
using mozilla.rv:0.9.4+.2001091021 on Debian Linux and I've seen this on the
above URL as well as on other sites with invalid/self-signed certificates. 

Comment 10

17 years ago
OK - Confirmed with 2001091101 linux :
/cvs/mozilla/mozilla/dist/bin/run-mozilla.sh: line 72: 13817 Segmentation fault
     $prog ${1+"$@"}
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 11

17 years ago
Created attachment 49022 [details]
GDB Backtrace

Comment 12

17 years ago
-> NSS / Libraries
Assignee: asa → wtc
Status: UNCONFIRMED → NEW
Component: Browser-General → Libraries
Ever confirmed: true
Product: Browser → NSS
QA Contact: doronr → sonmi
Version: other → unspecified

Comment 13

17 years ago
Nelson, could you please take a look at the stack trace
and see if we can avoid this crash (for example, when a
NULL 'cert' argument is passed to CERT_GetCertChainFromCert)?
Assignee: wtc → nelsonb
(Assignee)

Comment 14

17 years ago
The fix for this bug has already been reviewed and should be checked in 
shortly.  See bug 99052

*** This bug has been marked as a duplicate of 99052 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.