Zoom percentage label not aligned properly when placed in a toolbar

VERIFIED FIXED in Firefox 29

Status

()

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: mikedeboer, Assigned: mikedeboer)

Tracking

(Blocks 1 bug, {regression})

31 Branch
Firefox 31
All
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29 verified, firefox30 verified, firefox31 verified)

Details

(Whiteboard: [Australis:P4])

Attachments

(1 attachment)

Assignee

Description

5 years ago
After many attempts at fixing this before, the zoom percentage label doesn't get positioned in the middle when placed in the TabsToolbar, navbar or PersonalToolbar.

Let's fix this once and for all.
Assignee

Updated

5 years ago
Whiteboard: [Australis:P4]
Assignee

Comment 2

5 years ago
Comment on attachment 8400649 [details] [diff] [review]
Patch v1: fix zoom percentage label to be centered in any toolbar

On second thought, Mike, you have easier access to Mac, I believe...
Attachment #8400649 - Flags: review?(jaws) → review?(mconley)
Comment on attachment 8400649 [details] [diff] [review]
Patch v1: fix zoom percentage label to be centered in any toolbar

Review of attachment 8400649 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good! :) Thanks Mike!
Attachment #8400649 - Flags: review?(mconley) → review+
Assignee

Comment 4

5 years ago
Thanks!

Pushed as https://hg.mozilla.org/integration/fx-team/rev/5ad244ee8032
Whiteboard: [Australis:P4] → [Australis:P4][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/5ad244ee8032
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P4][fixed-in-fx-team] → [Australis:P4]
Target Milestone: --- → Firefox 31
Assignee

Comment 6

5 years ago
Comment on attachment 8400649 [details] [diff] [review]
Patch v1: fix zoom percentage label to be centered in any toolbar

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: When an OSX user puts the Zoom controls on a toolbar, he/ she will notice the zoom percentage label aligned too much toward the bottom of the button. This patches fixes that, regardless of the toolbar type.
Testing completed (on m-c, etc.): landed on m-c.
Risk to taking this patch (and alternatives if risky): minor
String or IDL/UUID changes made by this patch: n/a
Attachment #8400649 - Flags: approval-mozilla-beta?
Attachment #8400649 - Flags: approval-mozilla-aurora?
Attachment #8400649 - Flags: approval-mozilla-beta?
Attachment #8400649 - Flags: approval-mozilla-beta+
Attachment #8400649 - Flags: approval-mozilla-aurora?
Attachment #8400649 - Flags: approval-mozilla-aurora+
User Agents:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Firefox/31.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:30.0) Gecko/20100101 Firefox/30.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0

Verified this issue as fixed using:
- latest Firefox Nightly (build ID: 20140407030203)
- latest Firefox Aurora (build ID: 20140407004002)
- Firefox 29 beta 6 (build ID: 20140407135746).
You need to log in before you can comment on or make changes to this bug.