Bug 991273 (MediaSegmentBase)

Intermittent test_dataChannel_basicVideo.html,855796.html | application crashed [@ mozilla::MediaSegmentBase<mozilla::VideoSegment, ...] after "Assertion failure: aStart >= 0 && aEnd <= aSource.mDuration (Slice out of range)"

RESOLVED FIXED in Firefox 31

Status

()

defect
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: jesup, Assigned: padenot)

Tracking

(4 keywords)

unspecified
mozilla32
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox30 unaffected, firefox31 fixed, firefox32 fixed, firefox-esr24 unaffected, b2g-v1.4 unaffected, b2g-v2.0 fixed)

Details

Attachments

(1 attachment)

https://tbpl.mozilla.org/php/getParsedLog.php?id=37156180&tree=Mozilla-Inbound#error0

MediaSegment.h:271
   MOZ_ASSERT(aStart >= 0 && aEnd <= aSource.mDuration, "Slice out of range");
Summary: Intermittent MOZ_CRASH for slice-out-of-range in AppendSliceInternal() → Intermittent MOZ_ASSERT for slice-out-of-range in AppendSliceInternal()
Keywords: crash
Summary: Intermittent MOZ_ASSERT for slice-out-of-range in AppendSliceInternal() → Intermittent test_dataChannel_basicVideo.html | application crashed [@ mozilla::MediaSegmentBase<mozilla::VideoSegment, ...] after "Assertion failure: aStart >= 0 && aEnd <= aSource.mDuration (Slice out of range)"
Blocks: 818822
No longer depends on: 818822
Keywords: regression
Seen on Android and Mac (10.6 mostly, one 10.8) so far
https://tbpl.mozilla.org/php/getParsedLog.php?id=38113653&tree=Mozilla-Inbound
Summary: Intermittent test_dataChannel_basicVideo.html | application crashed [@ mozilla::MediaSegmentBase<mozilla::VideoSegment, ...] after "Assertion failure: aStart >= 0 && aEnd <= aSource.mDuration (Slice out of range)" → Intermittent test_dataChannel_basicVideo.html,855796.html | application crashed [@ mozilla::MediaSegmentBase<mozilla::VideoSegment, ...] after "Assertion failure: aStart >= 0 && aEnd <= aSource.mDuration (Slice out of range)"
https://tbpl.mozilla.org/php/getParsedLog.php?id=38548712&tree=Fx-Team

Is somebody going to look into this frequent, widespread (and therefore PITA to star) orange some time soon? It's been happening for 3 weeks now with no activity in the bug indicating it's being looked at by anybody.
Flags: needinfo?(paul)
I believe the actual cause is being worked on in other bugs, sorry about that.
Flags: needinfo?(paul)
Bug 998711 is fixed but this persists :(
Flags: needinfo?(paul)
Ryan, looks like 926606 is the same problem (although with a different stack), and Jesse has provided a testcase. I've checked locally, I can repro there. I've tried to fix it, but I'm a bit short on time at the moment, I'll see what I can do.

It seems to me that the problem is that for some reason, track is not ended, but we have less data than we though we should have (basically, we are underruning).
Depends on: 926606
Flags: needinfo?(paul)
Duplicate of this bug: 1007031
https://tbpl.mozilla.org/php/getParsedLog.php?id=39503389&tree=Fx-Team

Can we consider downgrading this to a warning for the time-being?
Flags: needinfo?(paul)
From comment 121 for revision 62b1d56d91e5:

Assertion failure: aStart >= 0 && aEnd <= aSource.mDuration (Slice out of range), at /builds/slave/m-in-osx64-d-00000000000000000/build/content/media/MediaSegment.h:295
mozilla::TrackUnionStream::ProcessInput(long long, long long, unsigned int) [content/media/TrackUnionStream.h:77]

https://hg.mozilla.org/integration/mozilla-inbound/annotate/62b1d56d91e5/content/media/MediaSegment.h#l295
https://hg.mozilla.org/integration/mozilla-inbound/annotate/62b1d56d91e5/content/media/TrackUnionStream.h#l77
Keywords: leave-open
Depends on: 957691
https://tbpl.mozilla.org/php/getParsedLog.php?id=42295093&tree=Mozilla-Beta

Please can we land this on Beta31? This technically can't land without approval since it touches non-test code.
Flags: needinfo?(paul)
Sorry Ryan, I missed your first message, I can ask for uplift.
Flags: needinfo?(paul)
This is not a functional change, but Ryan tells me he would be happier with it on all the branches. This is code that is being reworked at the moment, this probably will go away with the refactoring.
Attachment #8445228 - Flags: approval-mozilla-beta?
Attachment #8445228 - Flags: approval-mozilla-aurora?
Comment on attachment 8445228 [details]
Warn instead of asserting to make the Sheriff's life easier

Approving without risk evaluation. Looking at the patch, I am not afraid it is going to break anything.
Attachment #8445228 - Flags: approval-mozilla-beta?
Attachment #8445228 - Flags: approval-mozilla-beta+
Attachment #8445228 - Flags: approval-mozilla-aurora?
Attachment #8445228 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-beta/rev/c5eabaa4b266

Given comment 135, I'm going to go ahead and call this bug fixed since it sounds like any future fixes for the underlying problem won't be coming from this bug anyway. Note that this landed on m-c when it was still tracking Gecko 32, so this only needed to land on beta.
Status: NEW → RESOLVED
Closed: 5 years ago
Keywords: leave-open
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
No longer blocks: 1109405
Depends on: 1109405
You need to log in before you can comment on or make changes to this bug.