[B2G][Tarako] Cost Control bar in notification doesn't update info after switch off airplane mode

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: sarsenyev, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.3 unaffected, b2g-v1.3T unaffected)

Details

(Whiteboard: [tarako-exploratory])

Attachments

(2 attachments)

Description:
If from notification bar activate "Airplane" mode,"No SIM card information" appears on the screen, after turning off "Airplane mode" the "No SIM card" info still appears on the screen

Prerequisites:
Cost Control is not set up on the device

Repro Steps:
1) Update a Tarako to BuildID: 20140402094402
2) Slide down the notification bar to see the "New SIM card inserted" info
3) Tap the "Airplane" mode to activate it
4) After "No SIM inserted" info appears tap the "Airplane mode" icon again to turn it off

Actual:
SIM card status is not updated

Expected:
When Airplane mode is off, SIM card status is updated and "SIM card inserted" info re-appears

1.3 Environmental Variables:
Device: Tarako 1.3 MOZ
BuildID: 20140402094402
Gaia: 578fdccea89a88b417d296f8cf20b39099d44be4
Gecko: 34ed4cbc5a59
Version: 28.1
Firmware Version: sp8810


Notes:
To update the info a user needs to reopen the notification bar again
No Memory Reporting: Firewatch available

Repro frequency: 100% 5/5
See attached: logcat

The bug doesn't reproduce on 1.3 Buri device
1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140401164001
Gaia: c5cd3a11e91339163b351d50769eaca0067da860
Gecko: 5045a67b47ed
Version: 28.0
Firmware Version: v1.2-device.cfg
Posted file log04022014.txt
Is this happening on 1.4?
Keywords: qawanted
Component: Gaia::Homescreen → Gaia::System
QA Contact: demerick
QA Contact: demerick
The issue doesn't repro on 1.4 Buri device

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140326000201
Gaia: 7e705dd4718d528974d99ac31866318d7e201152
Gecko: 4889124accfa
Version: 30.0a2
Firmware Version: v1.2-device.cfg
Keywords: qawanted
blocking-b2g: --- → 1.3T?
ni? noef
Flags: needinfo?(noef)
Hi,

In the screenshot attached we can see that it is a dual SIM device, which is the default data SIM card?. 
In the description you mention "To update the info a user needs to reopen the notification bar again", when accessing again to the notification bar SIM2 is properly initiated a registered into the network?. Thanks!
Flags: needinfo?(noef) → needinfo?(sarsenyev)
I tried with 2 SIM Cards and with 1 SIM Card AT&T and T-Mobile
Same scenario, both SIM cards are registered into the network, but the notification info is not updated
Flags: needinfo?(sarsenyev)
The patch of the Bug 986358 - [Sora][IOT]"Not SIM inserted message" appears when SIM is alrady inserted was uplifted on 4/4. Could you re-check this with a build most recent?
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 986358
clear flag on a dup
blocking-b2g: 1.3T? → ---
It's a different issue, it's not a dupe.
The bug 986358 is fixed, here the issue still repro
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
So to be clear SIM car is registered but the info is not updated.

1.3 Environmental Variables:
Device: TaTarako 1.3 MOZ
BuildID: 20140407004001
Gaia: d9ac78148591a50356dd5a82d2d295eeb7c234a6
Gecko: f105ec652173
Version: 28.1
Firmware Version: sp8810
Moving to unaffected for 1.3T since the usage widget has been disabled for 1.3T.
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Closed: 5 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.