Closed Bug 991387 Opened 6 years ago Closed 6 years ago

[B2G][Tarako][Contacts] Importing an email account with less contacts than what is on the phone shows a negative number

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3 affected, b2g-v1.3T affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v1.3 --- affected
b2g-v1.3T --- affected

People

(Reporter: demerick, Unassigned)

Details

(Keywords: regression, Whiteboard: [tarako-exploratory])

Attachments

(2 files)

Attached file logcat.txt
Description:
If the user attempts to import an email account that has less contacts than what is on the phone they will incorrectly see a negative number.

Repro Steps:
1) Update a Tarako to BuildID: 20140402094402
2) Launch contacts from the home screen and add no less than five contacts
3) Tap the gear/settings icon in the top right corner
4) Tap 'Import Contacts'
5) Import contacts from a gmail or outlook account with less than five contacts

Actual:
The user will see a negative number of contacts to import

Expected:
The user should not see a negative number of contacts

1.3T Environmental Variables:
Device: Tarako 1.3T MOZ
BuildID: 20140402094402
Gaia: 578fdccea89a88b417d296f8cf20b39099d44be4
Gecko: 34ed4cbc5a59
Version: 28.1
Firmware Version: sp8810

Repro frequency: 100%
See attached: logcat.txt, screenshot

We are currently having issues with firewatch and cannot attach memory reports.
Attached image negative_contacts.png
This issue reproduces on the Buri 1.3 MOZ RIL

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140401004003
Gaia: 24f562fce468fc948ac9e6185e002c23350cb9ee
Gecko: 0adf24a785f2
Version: 28.0
Firmware Version: 

Importing contacts from an email account that has less contacts than what is on the phone will show a negative number during the import process.
Does this happen on 1.1?
Keywords: qawanted
QA Contact: jschmitt
(In reply to Jason Smith [:jsmith] from comment #2)
> Does this happen on 1.1?

Following the steps in Comment 0, I am unable to repro on 1.1 Buri build

Environmental Variables:
Device: Buri 1.1 MOZ
BuildID: 20140331041208
Gaia: 44a2ddf63373f8e95c784faf4ed4d60081699c61
Gecko: 170d87349060
Version: 18.0
Firmware Version: V1.2-device.cfg
Keywords: qawanted
QA Contact: jschmitt
After you select a checkbox or do select all, does the count of contacts available to import change to a positive number?
Keywords: qawanted
Keywords: regression
hi demerick and John, could you help to confirm comment 4's question
Flags: needinfo?(jschmitt)
Flags: needinfo?(demerick)
I have been unable to reproduce this on a Tarako running the latest 1.3T build or a Buri device running the latest 1.3 build.

I also tried to reproduce this issue on the Tarako and Buri builds mentioned in Comment 0 and Comment 1 and did not see the issue reproduce.

I have checked with the original reporter demerick and he has also been unable to reproduce this issue today.

Resolving this issue as works for me.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(jschmitt)
Flags: needinfo?(demerick)
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.