[Inspector] The inspector should not scroll the page to the top when invoked

RESOLVED DUPLICATE of bug 988102

Status

defect
RESOLVED DUPLICATE of bug 988102
5 years ago
a year ago

People

(Reporter: julienw, Unassigned)

Tracking

Trunk
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

5 years ago
STR:
* go to http://visionmedia.github.io/mocha/
* scroll down to asynchronous code (you can use the menu)
* press "ctrl shirt k" to open the dev tools
* click on "inspector"

Expected:
* the page stays at the same position

Actual:
* the page scrolls to the top

This makes the user very angry.

Tested on latest nightly.
Reporter

Updated

5 years ago
Blocks: firebug-gaps
No longer blocks: firebug-gaps
This is very annoying. Any idea what's going on? I guess we scrollIntoView the body.
Flags: needinfo?(mratcliffe)
Yup, I should fix this.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(mratcliffe)
Resolution: --- → DUPLICATE
Duplicate of bug: 988102

Updated

a year ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.