Closed Bug 991686 Opened 7 years ago Closed 7 years ago

[GTK3] download "Open containing folder" button does not open Files

Categories

(Core :: Widget: Gtk, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla31
Tracking Status
firefox31 --- fixed

People

(Reporter: jhorak, Assigned: jhorak)

References

Details

Attachments

(1 file, 1 obsolete file)

Description of problem:


Version-Release number of selected component (if applicable): 29a1 (Jan-17)


How reproducible: Always


Steps to Reproduce:
1. Download a file
2. From the door hanger or downloads window select the "open containing folder" icon

Actual results: Dialog appears asking for the user to set the default application for file links
 

Expected results: Nautilus/Files opens and the downloaded file is selected

Additional info: If a user sets /usr/bin/nautilus as the default app for file links Nautilus/Files is launched but the file is not selected.

Downstream bug: https://bugzilla.redhat.com/show_bug.cgi?id=1056322
Attached patch gtk3-build-with-gio.patch (obsolete) — Splinter Review
Attaching simple fix, we've missed some configure.in change.
Assignee: nobody → jhorak
Attachment #8401298 - Flags: review?(karlt)
Blocks: gtk3
Comment on attachment 8401298 [details] [diff] [review]
gtk3-build-with-gio.patch

"$MOZ_ENABLE_GTK" looks like the usual thing to test, but please ask a build peer, such as :glandium to review.
Attachment #8401298 - Flags: review?(karlt) → review-
Thanks for the review, asking Mike this time.
Attachment #8402574 - Flags: review?(mh+mozilla)
Attachment #8402574 - Flags: review?(mh+mozilla) → review+
Attachment #8401298 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/e9f369349de8
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
Blocks: 1034064
No longer blocks: 1034064
Keywords: verifyme
Based on the feedback provided by Mike in bug 982964:

"Gtk+3 is a work in progress currently, and there were many problems in 31 with
its. It may not even build. The first version that kind of works in 32, but
really, I think it's not worth worrying more than 33 at this point.
"
I'm removing the "verifyme" keyword.
Keywords: verifyme
QA Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.