Closed Bug 991791 Opened 6 years ago Closed 6 years ago

Crash in nsMemoryReportManager::StartGettingReports() while monkey testing

Categories

(Core :: XPCOM, defect)

30 Branch
ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla31
blocking-b2g 1.4+
Tracking Status
firefox29 --- unaffected
firefox30 --- fixed
firefox31 --- fixed
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: ggrisco, Assigned: jld)

References

Details

(Keywords: crash, Whiteboard: [b2g-crash])

Crash Data

Attachments

(3 files)

No clear STR since this was found during monkey testing.  But we have seen this crash many times with same Crash reason:  SIGSEGV and Crash address: 0x10.

We have seen this with the following signatures:

[@ nsMemoryReporterManager::StartGettingReports() | nsRunnableMethodImpl<tag_nsresult (mozilla::dom::NotificationPermissionRequest::*)(), void, true>::Run() | MinimizeMemoryUsageRunnable::Run | nsThread::ProcessNextEvent(bool, bool*) ]

[@ nsMemoryReporterManager::StartGettingReports() | nsRunnableMethodImpl<tag_nsresult (mozilla::MediaDecoderStateMachine::*)(), void, true>::Run() | MinimizeMemoryUsageRunnable::Run | nsThread::ProcessNextEvent(bool, bool*) ]

[@ nsMemoryReporterManager::StartGettingReports() | nsRunnableMethodImpl<unsigned int (mozilla::MediaDecoderStateMachine::*)(), void, true>::Run() | MinimizeMemoryUsageRunnable::Run | nsThread::ProcessNextEvent(bool, bool*) ]
blocking-b2g: --- → 1.4?
Attached file EXTRA file attachment
attached .EXTRA file has some log attached
Component: General → XPCOM
Keywords: crash
Product: Firefox OS → Core
Whiteboard: [b2g-crash]
Version: unspecified → 30 Branch
See Also: → 991208
Thought it might be related to 973090, although without gc/cc logs we are still seeing this crash.
Jed,

I think this crash is also happening during get_about_memory.py. Is it related to bug 973090?
Can you look at comment 3.
Flags: needinfo?(jld)
(In reply to Diego Wilson [:diego] from comment #3)
> I think this crash is also happening during get_about_memory.py. Is it
> related to bug 973090?

It's not a SIGSYS.  But it probably is fallout from bug 946407.  Specifically: now that reporting on the parent process can be done asynchronously after minimizing memory utilizations, it's possible that other things (all the child processes finishing, or reaching the timeout) could happen first.
Assignee: nobody → jld
Flags: needinfo?(jld)
Depends on: 946407
See Also: 991208
More explanation in the commit message and comments.

Tried: https://tbpl.mozilla.org/?tree=Try&rev=5432ae25f6ce
Attachment #8402869 - Flags: review?(n.nethercote)
Attachment #8402869 - Flags: review?(n.nethercote) → review+
blocking-b2g: 1.4? → 1.4+
Hi Jed,

I can't reproduce the crash anymore with your patch. Thanks!
https://hg.mozilla.org/mozilla-central/rev/997be3bd8c8f
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
We cannot create a test case with this scenario in Moztrap.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Flags: in-moztrap?(rmead)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: in-moztrap?(rmead)
Flags: in-moztrap-
You need to log in before you can comment on or make changes to this bug.