Closed Bug 991873 Opened 6 years ago Closed 5 years ago

[B2G][Tarako][Dialer] With dual sims there is no way to tell which phone number an incoming call is for

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3 unaffected, b2g-v1.3T affected)

RESOLVED DUPLICATE of bug 947131
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- affected

People

(Reporter: demerick, Unassigned)

Details

(Whiteboard: [tarako-exploratory])

Attachments

(4 files)

Attached file logcat.txt
Description:
If the user has two sims and receive calls from a few different phone numbers the user will not be able to tell which sim received which calls.

This could be an issue if the user attempts to call back a phone number that was meant for a different sim/number.

Repro Steps:
1) Update a Tarako to BuildID: 20140403004001
2) You will need two sim cards and at least two other devices
3) Put two active SIM cards with phone numbers in the Tarako device
4) Call each sim card phone number from multiple other devices
5) Launch the Dialer app from the home screen
6) Tap the call log/phone icon in the bottom left of the screen

Actual:
The user is unable to tell which phone number/sim was being called in the call log

Expected:
The user should be able to tell which phone number/sim received which call

1.3T Environmental Variables:
Device: Tarako 1.3T MOZ
BuildID: 20140403004001
Gaia: 8d212f640014db62c622e8c939ddbf8595f00438
Gecko: ddd7ba612cfe
Version: 28.1
Firmware Version: sp8810

Repro frequency: 100%
See attached: screenshot, logcat.txt
Attached image call_log_dualSims.png
This issue does not reproduce on Buri v1.3 MOZ RIL

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140401004003
Gaia: 24f562fce468fc948ac9e6185e002c23350cb9ee
Gecko: 0adf24a785f2
Version: 28.0
Firmware Version: v1.2-device.cfg

There is no option for dual sims on the Buri device.
Eric, can you see if this issue reproduces on a fugu device?
Flags: needinfo?(echang)
Keywords: qawanted
Attached image v1.4-20140407041552.png
v1.4 20140407041552 is okay
Flags: needinfo?(echang)
Attached image v1.3-20140319041535.png
v1.3 20140319041535 doesn't have that feature yet, I am trying to build today's v1.3 to make sure..
https://bugzilla.mozilla.org/show_bug.cgi?id=947131 Only in v1.4 and above.
v1.3 20140407100112 also doesn't have that.
So is this a dupe of bug 947131 then?
Flags: needinfo?(echang)
Keywords: qawanted
That is the meta bug for some of the call log features, although it doesn't have meta in the title.
Flags: needinfo?(echang)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 947131
You need to log in before you can comment on or make changes to this bug.