Closed Bug 991926 Opened 7 years ago Closed 7 years ago

[e10s] crash in mozalloc_abort(char const* const) | NS_DebugBreak | mozilla::dom::ContentChild::ProcessingError(mozilla::ipc::HasResultCodes::Result)

Categories

(Core :: IPC, defect)

All
Windows NT
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 961343
Tracking Status
e10s + ---
firefox29 --- affected
firefox30 --- affected
firefox31 --- affected

People

(Reporter: cpeterson, Unassigned)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-3f589130-15a0-4ca7-a7f4-8c0b72140402.
=============================================================

More crash reports:
https://crash-stats.mozilla.com/report/list?product=Firefox&range_value=28&range_unit=days&date=2014-04-03&signature=mozalloc_abort(char+const*+const)+|+NS_DebugBreak+|+mozilla%3A%3Adom%3A%3AContentChild%3A%3AProcessingError(mozilla%3A%3Aipc%3A%3AHasResultCodes%3A%3AResult)#tab-reports

Frame 	Module 	Signature 	Source
0 	mozalloc.dll 	mozalloc_abort(char const * const) 	memory/mozalloc/mozalloc_abort.cpp
1 	xul.dll 	NS_DebugBreak 	xpcom/base/nsDebugImpl.cpp
2 	xul.dll 	mozilla::dom::ContentChild::ProcessingError(mozilla::ipc::HasResultCodes::Result) 	dom/ipc/ContentChild.cpp
3 	xul.dll 	mozilla::ipc::MessageChannel::MaybeHandleError(mozilla::ipc::HasResultCodes::Result,char const *) 	ipc/glue/MessageChannel.cpp
4 	xul.dll 	mozilla::ipc::MessageChannel::DispatchUrgentMessage(IPC::Message const &) 	ipc/glue/MessageChannel.cpp
5 	xul.dll 	mozilla::ipc::MessageChannel::ProcessPendingUrgentRequest() 	ipc/glue/MessageChannel.cpp
6 	xul.dll 	mozilla::ipc::MessageChannel::SendAndWait(IPC::Message *,IPC::Message *) 	ipc/glue/MessageChannel.cpp
7 	xul.dll 	mozilla::ipc::MessageChannel::Send(IPC::Message *,IPC::Message *) 	ipc/glue/MessageChannel.cpp
8 	xul.dll 	mozilla::dom::PBrowserChild::SendSyncMessage(nsString const &,mozilla::dom::ClonedMessageData const &,nsTArray<mozilla::jsipc::CpowEntry> const &,IPC::Principal const &,nsTArray<nsString> *) 	obj-firefox/ipc/ipdl/PBrowserChild.cpp
9 	xul.dll 	mozilla::dom::TabChild::DoSendBlockingMessage(JSContext *,nsAString_internal const &,mozilla::dom::StructuredCloneData const &,JS::Handle<JSObject *>,nsIPrincipal *,nsTArray<nsString> *,bool) 	dom/ipc/TabChild.cpp
10 	xul.dll 	nsFrameMessageManager::SendMessage(nsAString_internal const &,JS::Handle<JS::Value>,JS::Handle<JS::Value>,nsIPrincipal *,JSContext *,unsigned char,JS::MutableHandle<JS::Value>,bool) 	content/base/src/nsFrameMessageManager.cpp
11 	xul.dll 	nsFrameMessageManager::SendSyncMessage(nsAString_internal const &,JS::Handle<JS::Value>,JS::Handle<JS::Value>,nsIPrincipal *,JSContext *,unsigned char,JS::MutableHandle<JS::Value>) 	content/base/src/nsFrameMessageManager.cpp
12 	xul.dll 	mozilla::dom::TabChildGlobal::SendSyncMessage(nsAString_internal const &,JS::Handle<JS::Value>,JS::Handle<JS::Value>,nsIPrincipal *,JSContext *,unsigned char,JS::MutableHandle<JS::Value>) 	dom/ipc/TabChild.h
13 	xul.dll 	NS_InvokeByIndex 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp
14 	xul.dll 	XPC_WN_CallMethod(JSContext *,unsigned int,JS::Value *) 	js/xpconnect/src/XPCWrappedNativeJSOps.cpp
15 	mozjs.dll 	js::Invoke(JSContext *,JS::CallArgs,js::MaybeConstruct) 	js/src/vm/Interpreter.cpp
16 	mozjs.dll 	Interpret 	js/src/vm/Interpreter.cpp
17 	mozjs.dll 	js::RunScript(JSContext *,js::RunState &) 	js/src/vm/Interpreter.cpp
18 	mozjs.dll 	js::Invoke(JSContext *,JS::CallArgs,js::MaybeConstruct) 	js/src/vm/Interpreter.cpp
19 	mozjs.dll 	js::Invoke(JSContext *,JS::Value const &,JS::Value const &,unsigned int,JS::Value const *,JS::MutableHandle<JS::Value>) 	js/src/vm/Interpreter.cpp
20 	mozjs.dll 	JS_CallFunctionValue(JSContext *,JS::Handle<JSObject *>,JS::Handle<JS::Value>,JS::HandleValueArray const &,JS::MutableHandle<JS::Value>) 	js/src/jsapi.cpp
21 	xul.dll 	nsFrameMessageManager::ReceiveMessage(nsISupports *,nsAString_internal const &,bool,mozilla::dom::StructuredCloneData const *,CpowHolder *,nsIPrincipal *,nsTArray<nsString> *) 	content/base/src/nsFrameMessageManager.cpp
22 	xul.dll 	mozilla::dom::TabChild::RecvAsyncMessage(nsString const &,mozilla::dom::ClonedMessageData const &,nsTArray<mozilla::jsipc::CpowEntry> const &,IPC::Principal const &) 	dom/ipc/TabChild.cpp
23 	xul.dll 	mozilla::dom::PBrowserChild::OnMessageReceived(IPC::Message const &) 	obj-firefox/ipc/ipdl/PBrowserChild.cpp
24 	xul.dll 	mozilla::dom::PContentChild::OnMessageReceived(IPC::Message const &) 	obj-firefox/ipc/ipdl/PContentChild.cpp
25 	xul.dll 	mozilla::ipc::MessageChannel::DispatchAsyncMessage(IPC::Message const &) 	ipc/glue/MessageChannel.cpp
26 	xul.dll 	mozilla::ipc::MessageChannel::DispatchMessageW(IPC::Message const &) 	ipc/glue/MessageChannel.cpp
27 	xul.dll 	mozilla::ipc::MessageChannel::OnMaybeDequeueOne() 	ipc/glue/MessageChannel.cpp
28 	xul.dll 	MessageLoop::RunTask(Task *) 	ipc/chromium/src/base/message_loop.cc
29 	xul.dll 	MessageLoop::DeferOrRunPendingTask(MessageLoop::PendingTask const &) 	ipc/chromium/src/base/message_loop.cc
30 	xul.dll 	MessageLoop::DoWork() 	ipc/chromium/src/base/message_loop.cc
31 	xul.dll 	mozilla::ipc::MessagePumpForChildProcess::Run(base::MessagePump::Delegate *) 	ipc/glue/MessagePump.cpp
32 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc
33 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
34 	xul.dll 	nsBaseAppShell::Run() 	widget/xpwidgets/nsBaseAppShell.cpp
35 	xul.dll 	nsAppShell::Run() 	widget/windows/nsAppShell.cpp
36 	xul.dll 	XRE_RunAppShell 	toolkit/xre/nsEmbedFunctions.cpp
37 	xul.dll 	mozilla::ipc::MessagePumpForChildProcess::Run(base::MessagePump::Delegate *) 	ipc/glue/MessagePump.cpp
38 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc
39 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
40 	xul.dll 	XRE_InitChildProcess 	toolkit/xre/nsEmbedFunctions.cpp
41 	plugin-container.exe 	NS_internal_main(int,char * *) 	ipc/app/MozillaRuntimeMain.cpp
42 	plugin-container.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp
43 	plugin-container.exe 	__tmainCRTStartup 	f:/dd/vctools/crt_bld/self_x86/crt/src/crtexe.c
44 	kernel32.dll 	kernel32.dll@0x1919f 	
45 	ntdll.dll 	ntdll.dll@0x4a8cb 	
46 	ntdll.dll 	ntdll.dll@0x4a8a1
tracking-e10s: --- → +
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 961343
You need to log in before you can comment on or make changes to this bug.