"The CLOBBER file has been updated" build-failure message is now printed twice

RESOLVED FIXED in mozilla31

Status

defect
RESOLVED FIXED
5 years ago
Last year

People

(Reporter: dholbert, Assigned: glandium)

Tracking

Trunk
mozilla31
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Reporter

Description

5 years ago
STR:
 1. Have a non-empty objdir. (and don't have AUTOCLOBBER in your mozconfig)
 2. Modify the CLOBBER file
 3. run ./mach build

ACTUAL RESULTS: The entire chunk of output about
 "The CLOBBER file has been updated [etc etc]"
is printed twice now.

EXPECTED RESULTS: This information should only be printed once.

I just noticed this for the first time now, and I'm used to seeing this a few times a week, so I suspect this regressed in the past few days or so.

My build that reproduces this is at mozilla-central changeset 6c924a018540.
Reporter

Updated

5 years ago
Summary: "The CLOBBER file has been updated" message is now printed twice → "The CLOBBER file has been updated" build-failure message is now printed twice
Assignee

Updated

5 years ago
Blocks: 990848
Assignee

Comment 2

5 years ago
Interestingly, I can't reproduce.
Assignee

Comment 3

5 years ago
Scrap that, I can. It doesn't reproduce with mach configure but does with mach build.
Assignee

Comment 4

5 years ago
I even have it printed three times.
Assignee

Comment 5

5 years ago
The problem is that mach build calls make -f client.mk, which emits the message when it tries to create .mozconfig.mk (and doesn't). But that error is ignored, so it goes on and calls make -f client.mk realbuild, which emits the message again when it tries to create .mozconfig.mk. But that error is ignored again, so it goes on and calls make -f client.mk configure, which emits the message yet again, but this time, since configure depends on CLOBBER, and that's the rule that fails, it errors out.
Attachment #8401664 - Flags: review?(mshal)
Assignee

Updated

5 years ago
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
Attachment #8401664 - Flags: review?(mshal) → review+
Reporter

Comment 7

5 years ago
I've confirmed that this is fixed for me on inbound.

Thanks!
https://hg.mozilla.org/mozilla-central/rev/cf2c03bddca6
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31

Updated

Last year
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.