Closed Bug 992108 Opened 7 years ago Closed 7 years ago

[Tarako][Bluetooth] Apps are killed and it goes back to home screen after tapping on the paired device when transferring a file via bluetooth

Categories

(Firefox OS Graveyard :: Gaia::Bluetooth, defect)

Other
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.3T affected)

RESOLVED FIXED
Tracking Status
b2g-v1.3T --- affected

People

(Reporter: bli, Unassigned)

References

Details

(Whiteboard: OOM [sprd296906] [partner-blocker])

Attachments

(1 file)

log
103.77 KB, text/x-log
Details
Environment:
---------------------------------------------------------
Gaia      32e15ec78cb245576a382468790d8f65461a5b3d
Gecko https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/e20c64a0ccd3
BuildID   20140403164001
Version   28.1
ro.build.version.incremental=eng.cltbld.20140403.201900
ro.build.date=Thu Apr  3 20:19:07 EDT 2014


Steps to reproduce:
----------------------------------------------------------
1. Launch Settings
2. Enable bluetooth and pair with another device
3. Send a file via bluetooth
   e.g. Goto Gallery—>Tap on a picture—>Tap on the 'share' icon—>Tap on 'bluetooth transfer'
        Goto Music—>Tap on a song—>Tap on the 'share' icon—>Tap on 'bluetooth transfer'

4. Choose the paired device


Actual result:
---------------------------------- 
After tapping on the paired device, it goes back to home screen.


Additional info:
----------------------------------
1. The notification can be shown correctly.
2. The file can be sent via bluetooth successfully.
blocking-b2g: --- → 1.3T?
Attached file log
it looks like LMK kicked in and kill the gallery/music app, since file transfer still works, lets not block on it. thanks
blocking-b2g: 1.3T? → -
Whiteboard: OOM → OOM [MP_Blocker]
Whiteboard: OOM [MP_Blocker] → OOM
We still need to fix it for 1.3T.
blocking-b2g: - → 1.3T?
Hi James: Is the side-effect of bt firmware issue?
Flags: needinfo?(james.zhang)
(In reply to thomas tsai from comment #4)
> Hi James: Is the side-effect of bt firmware issue?

No, it happened before we upgrade bt firmware.
Flags: needinfo?(james.zhang)
Re-nominate to 1.3T+ as partner's blocker
blocking-b2g: 1.3T? → 1.3T+
I think this is a dupe of bug 996912 so qawanted
Keywords: qawanted
(In reply to Fabrice Desré [:fabrice] from comment #7)
> I think this is a dupe of bug 996912 so qawanted

No, share music with bluetooth transfer when music playing, music app is killed, but bluetooth transfer is ok.
It has 100% reproduce rate on latest build.
I think you should group bluetooth transfer app into parent app.
Flags: needinfo?(fabrice)
I verify on my Tarako with below build and it's fine
It won't kill apps while transferring a file via bluetooth
test content: 1.5MB image and 3.9MB music
believe apps be killed is due to memory pressure and same with bug#996912
Keywords: qawanted
(In reply to Mike Lien[:mlien] from comment #9)
> I verify on my Tarako with below build and it's fine
> It won't kill apps while transferring a file via bluetooth
> test content: 1.5MB image and 3.9MB music
> believe apps be killed is due to memory pressure and same with bug#996912

Build Info
  Gaia      f0872318d46781bb59d0a13a2e1fffb115b8ca2b
  Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/9ff031daa73c
  BuildID   20140417152301
  Version   28.1
(In reply to James Zhang from comment #8)
> (In reply to Fabrice Desré [:fabrice] from comment #7)
> > I think this is a dupe of bug 996912 so qawanted
> 
> No, share music with bluetooth transfer when music playing, music app is
> killed, but bluetooth transfer is ok.
> It has 100% reproduce rate on latest build.
> I think you should group bluetooth transfer app into parent app.

James, if we're able to transfer files via BT app(activity), the following behaviour and UI flow are maintained in System app. I don't understand to group it in parent app. Could you give more explanation in this part?
(In reply to Ian Liu [:ianliu] from comment #11)
> (In reply to James Zhang from comment #8)
> > (In reply to Fabrice Desré [:fabrice] from comment #7)
> > > I think this is a dupe of bug 996912 so qawanted
> > 
> > No, share music with bluetooth transfer when music playing, music app is
> > killed, but bluetooth transfer is ok.
> > It has 100% reproduce rate on latest build.
> > I think you should group bluetooth transfer app into parent app.
> 
> James, if we're able to transfer files via BT app(activity), the following
> behaviour and UI flow are maintained in System app. I don't understand to
> group it in parent app. Could you give more explanation in this part?

"transfer files via BT app" is ok, "group it in parent app" means using activity too.
Whiteboard: OOM → OOM [sprd296906]
update today's daily build result
Gaia      68e072af2348c46fbff8a35d99ff10caeab16880
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/a8cc1aaec6a3
BuildID   20140420164002
Version   28.1

1. due to current image limitation is 2M pixels, comment 9's 1.5MB image exceed this limitation
change another one test transfer via bluetooth is fine and gallery doesn't be killed

2. while transferring music via bluetooth, result is same as comment 8, transfer is fine but music app is killed
Whiteboard: OOM [sprd296906] → OOM [sprd296906] [partner-blocker]
No longer blocks: 995122
Hi Dkuo, 
please take Bug 998913. we do not need share via "Bluetooth transfer" opt for music app.
Flags: needinfo?(dkuo)
This has nothing to do with Music app. Please do not throw bug to people without proper technical analysis.

This bug is can be fixed by proposed fix in bug 989742.
Depends on: 989742
Flags: needinfo?(dkuo)
Tim, so we can close this one?
Flags: needinfo?(fabrice)
Hi Tim, we have triaged yesterday with Thomas, Steven, Joe to make this decision because we got info it's due to OOM when playing music and share music via Bluetooth transfer same time. sorry that if OOM is not the case / root cause, i will remove this request, i'm happy to keep it.
(In reply to Marvin Khoo [:Marvin_Khoo] from comment #17)

It's fine. Sorry for not joining the triage session.

(In reply to Fabrice Desré [:fabrice] from comment #16)
> Tim, so we can close this one?

Let's keep this open and verify once bug 989742 is fixed.
let's put this back to 1.3T? and wait for 989742
blocking-b2g: 1.3T+ → 1.3T?
Removing this from the nom queue.
blocking-b2g: 1.3T? → ---
qawanted to verify this bug since bug 989742 is landed.

Add the bug back to the queue.
blocking-b2g: --- → 1.3?
Keywords: qawanted
Tried on build 20140424014003, it didn't go back to home screen and apps were not killed either after tapping on the paired device.


Build Info:
----------------------------------------------------
Gaia      706f474230432c8cb01e124aee2c055ec902aa1d
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/26ef3dded9ff
BuildID   20140424014003
Version   28.1
ro.build.version.incremental=eng.cltbld.20140424.051740
ro.build.date=Thu Apr 24 05:17:48 EDT 2014
Removing qawanted per comment 22.
Keywords: qawanted
Status: NEW → RESOLVED
blocking-b2g: 1.3? → ---
Closed: 7 years ago
Resolution: --- → WORKSFORME
Marking fixed by the dependency.
Resolution: WORKSFORME → FIXED
You need to log in before you can comment on or make changes to this bug.