Closed Bug 992215 Opened 7 years ago Closed 7 years ago

[camera] slow responsiveness/large jank when closing Options (often also when opening)

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.0+)

RESOLVED WORKSFORME
1.4 S6 (25apr)
blocking-b2g 2.0+

People

(Reporter: aryx, Assigned: Eli)

Details

(Keywords: perf, Whiteboard: [c=progress p=3 s=2014.04.25 u=2.0])

Boot2Gecko 1.5.0.0-prerelease 20140404024526 on Keon

When opening the Options in Camera by tapping on the button, it often takes very long. The issue is even more reproducible on closing. The developer HUD says the jank is either ~6100ms or ~12100ms.
Summary: [camera] slow responsiveness/large junk when closing Options (often also when opening) → [camera] slow responsiveness/large jank when closing Options (often also when opening)
blocking-b2g: --- → 2.0+
Keywords: perf
Priority: -- → P1
Whiteboard: [c=progress p= s= u=2.0]
Assignee: nobody → eperelman
Whiteboard: [c=progress p= s= u=2.0] → [c=progress p=3 s= u=2.0]
The issue is gone on my device (Geeksphone Keon running 2.0.0.0-prerelease 20140423035439).
Sounds like a short-term Gecko rendering regression. Closing this. Feel free to re-open if it re-surfaces.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [c=progress p=3 s= u=2.0] → [c=progress p=3 s=2014.04.25 u=2.0]
Target Milestone: --- → 1.4 S6 (25apr)
You need to log in before you can comment on or make changes to this bug.