Assertions when tree has no header

VERIFIED FIXED in M9

Status

()

Core
XUL
P2
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: Steve Lamm, Assigned: David Hyatt)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [08.13.99]waiting for reporter to reply)

(Reporter)

Description

19 years ago
I want to make the flash panel have no header.
If I take out the header, I get a crash.
If I leave an empty one, I get a pile of assertions.
(Reporter)

Updated

19 years ago
Summary: Crash when tree has no header → Assertions when tree has no header
(Reporter)

Comment 1

19 years ago
here's the stack trace:
nsDebug::Assertion(char * 0x01c72b88, char * 0x01c72b74, char * 0x01c72b38, int
2452) line 167 + 13 bytes
nsTableFrame::SetColumnDimensions(int 1875) line 2452 + 37 bytes
nsTableFrame::Reflow(nsTableFrame * const 0x02c45464, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 2621
nsTreeFrame::Reflow(nsTreeFrame * const 0x02c45464, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 294
nsContainerFrame::ReflowChild(nsIFrame * 0x02c45460, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 395 + 28 bytes
nsTableOuterFrame::Reflow(nsTableOuterFrame * const 0x02c453e4, nsIPresContext &
{...}, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned
int & 0) line 1006 + 37 bytes
nsBoxFrame::FlowChildAt(nsIFrame * 0x02c453e0, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0,
int 1, nsIFrame * & 0x00000000) line 725
nsBoxFrame::FlowChildren(nsIPresContext & {...}, nsHTMLReflowMetrics & {...},
const nsHTMLReflowState & {...}, unsigned int & 0, nsRect & {...}, nsIFrame * &
0x00000000) line 421
nsBoxFrame::Reflow(nsBoxFrame * const 0x0228502c, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 292
nsContainerFrame::ReflowChild(nsIFrame * 0x02285028, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 395 + 28 bytes
RootFrame::Reflow(RootFrame * const 0x02c33984, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 242
nsContainerFrame::ReflowChild(nsIFrame * 0x02c33980, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 395 + 28 bytes
ViewportFrame::Reflow(ViewportFrame * const 0x02c8b864, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 440
PresShell::InitialReflow(PresShell * const 0x02ab3620, int 4125, int 1875) line
929
XULDocumentImpl::StartLayout() line 3984
XULDocumentImpl::EndLoad(XULDocumentImpl * const 0x02a83500) line 1867
XULContentSinkImpl::DidBuildModel(XULContentSinkImpl * const 0x02a526e0, int 1)
line 516
CWellFormedDTD::DidBuildModel(CWellFormedDTD * const 0x02aa4d30, unsigned int 0,
int 1, nsIParser * 0x02a52790, nsIContentSink * 0x02a526e0) line 286 + 20 bytes
nsParser::DidBuildModel(unsigned int 0) line 525 + 55 bytes
nsParser::ResumeParse(nsIDTD * 0x00000000) line 886
nsParser::EnableParser(int 1) line 615 + 19 bytes
XULContentSinkImpl::DoneLoadingScript(nsIUnicharStreamLoader * 0x02c38bc0,
nsString & {...}, void * 0x02a526e0, unsigned int 0) line 1511
nsUnicharStreamLoader::OnStopRequest(nsUnicharStreamLoader * const 0x02c38bc4,
nsIURI * 0x02c379c0, unsigned int 0, unsigned short * 0x02c66a40) line 156 + 31
bytes
nsDocumentBindInfo::OnStopRequest(nsDocumentBindInfo * const 0x02c38e30, nsIURI
* 0x02c379c0, unsigned int 0, unsigned short * 0x02c66a40) line 2019 + 30 bytes
OnStopRequestProxyEvent::HandleEvent(OnStopRequestProxyEvent * const 0x02c66970)
line 593 + 45 bytes
StreamListenerProxyEvent::HandlePLEvent(PLEvent * 0x02c66974) line 473 + 12
bytes
PL_HandleEvent(PLEvent * 0x02c66974) line 493 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00ed6640) line 454 + 9 bytes
_md_EventReceiverProc(void * 0x027b02d2, unsigned int 49338, unsigned int 0,
long 15558208) line 912 + 9 bytes
USER32! 77e713ed()
(Reporter)

Comment 2

19 years ago
*** Bug 9895 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

19 years ago
Priority: P3 → P2
(Reporter)

Comment 3

19 years ago
I still see this.
(Reporter)

Updated

19 years ago
Blocks: 8836

Updated

19 years ago
Blocks: 10950
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

19 years ago
Fixed.  Trees can now have no header.

Updated

19 years ago
Whiteboard: [08.13.99]waiting for reporter to reply

Comment 5

19 years ago
steve, does this work for you now? can i mark it verified?
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

19 years ago
This works fine now. Marking VERIFIED.
You need to log in before you can comment on or make changes to this bug.