Closed Bug 992345 Opened 6 years ago Closed 6 years ago

[B2G][Lockscreen] Lockscreen appears horizontal instead of vertical on landscape

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
1.4 S6 (25apr)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: psiphantong, Assigned: gweng)

References

()

Details

(Keywords: regression, Whiteboard: [1.4-camera-exploratory])

Attachments

(3 files)

Attached image IMG_0080.jpg
Description:
when holding the power button on landscape, the power screen will appear. Press  the power button until the screen is black, press it again and the lockscreen appears horizontal instead of vertical.

Repro Steps:
1) On landscape, go to Gallery
2) Hold the power button, switch between camera and thumbnail view 
3) Press the power button on the power screen
4) Press the power button again


Actual:
On landscape, the lockscreen appears horizontal 

Expected:
On landscape, the lockscreen should appear vertical

v1.4 Environmental Variables:
Device: Buri v1.4 MOZ
BuildID: 20140403000210
Gaia: b4f3b84ec68233a99fd5865c15cfe28aebe26531
Gecko: 5bccd264a0e3
Version: 30.0a2
Firmware Version: v1.2-device.cfg


keywords:Lockscreen, horizontal, vertical, landscape

Repro frequency: (3/3, 100%)
See attached: (screenshot)
Whiteboard: [1.4-camera-exploratory]
Does this happen on 1.3?
Keywords: qawanted
Unable to reproduce issue on latest Buri 1.3 build.

Issue was not reproduced after 10 attempts despite having a 100% repro rate on Buri 1.4

1.3 Environmental Variables:
Device: buri 1.3 MOZ
BuildID: 20140407004003
Gaia: 9555c6d1b40ee40ac0713bba9f54d3943aff635f
Gecko: 4bba1932fb68
Version: 28.0
Firmware Version: v1.2-device.cfg
Keywords: qawanted
QA Contact: ddixon
Can we get a video specifically showing what happens after you unlock the screen in landscape?
Keywords: qawanted, regression
Keywords: qawanted
Ok - the video shows evidence here that we're showing the lockscreen in landscape mode in which you cannot unlock the device. You can however, move it back to portrait and be able to unlock the device. So I'd classify this bug as exposing broken UX & a regression.
blocking-b2g: --- → 1.4?
lockscreen should never be in landscape mode.  blocking 1.4+
blocking-b2g: 1.4? → 1.4+
I think the repro step somehow makes the orientation lock failed and we didn't try to re-lock.

:snowmantw, could you resolve this?
Flags: needinfo?(gweng)
Handling. May be an one-line fix.
Flags: needinfo?(gweng)
Attached file Patch
Patch. Will set review after a video and Travis is green.
Now I'm solving this on v1.4 while I'm waiting Travis.
Assignee: nobody → gweng
Comment on attachment 8405966 [details] [review]
Patch

Patch on the master branch.
Attachment #8405966 - Flags: review?(timdream)
Attached file Patch v1.4
Patch for v1.4.
Attachment #8406003 - Flags: review?(timdream)
Attachment #8405966 - Flags: review?(timdream) → review+
Comment on attachment 8406003 [details] [review]
Patch v1.4

You need to fill the approval-gaia-v1.4 form.
Attachment #8406003 - Flags: review?(timdream)
Attachment #8406003 - Flags: review+
Attachment #8406003 - Flags: approval-gaia-v1.4?
Greg,

ni for gaia form to be filled here
Flags: needinfo?(gweng)
master: https://github.com/mozilla-b2g/gaia/commit/d50d2f737e179b71a72c687a5329842d562de9f1

I'll handle v1.4 patch later.
Flags: needinfo?(gweng)
You should close the bug when it reaches master. and people is still waiting for approval-gaia-v1.4 form.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(gweng)
Resolution: --- → FIXED
[PATCH] Fix the orientation lock in LockScreen when screenchange

[Approval Request Comment]

[Bug caused by] (feature/regressing bug #): seems existing since the v1.4 LockScreen, but I don't know the exact bug

[User impact] if declined: when user open an app in landscape and then lock the screen, because of lacking the corresponding locking code in the event handler, the orientation would not keep in the portrait mode. This affects the LockScreen in v1.4. 

[Testing completed]: Passed all tests on Travis and on real device.

[Risk to taking this patch] (and alternatives if risky): none that I can think of, the change only improve the LockScreen and not change any behavior of it.

[String changes made]: none
Flags: needinfo?(gweng)
Target Milestone: --- → 1.4 S6 (25apr)
Removing "regression window wanted" as issue is Resolved Fixed.
Depends on: 1018364
You need to log in before you can comment on or make changes to this bug.