Acoustic new mail notification not working

VERIFIED WORKSFORME

Status

MailNews Core
Backend
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Marcus Münch, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
In all versions since Sept. 4, 2001 the acoustic mail notification does not
work. I switched back to 0.93 relaese and everything works fine. I don't know in
wich version this bug appeared first.
I use a custom wave file via

user_pref("mail.biff.default_sound_url",
"file:///C|/download/sounds/worms-eng/incoming.wav");

in prefs.js, could this be the problem?

Comment 1

17 years ago
This doesn't work since august 30, probably with the fix of bug 71143, see my
comments starting on 2001-08-30 in bug 64475, it says it all. Seems like moz
isn't keeping the line
user_pref("mail.biff.play_sound",true)
in prefs.js even if you add it every time.

Comment 2

17 years ago
I'm getting this in build 20010920 (I CAN hear the sound)

If this bug still exists, please comment.
(Reporter)

Comment 3

17 years ago
I still have no sound with build 2001092308 (Mozilla 0.94+), but I hear sound
with 0.93 and Netscape 6.1 (win2k)

Comment 4

17 years ago
working now on windows, moz trunk build 2001101003, though it doesn't work
through the prefs.js settings anymore, but uses the sound indicated by the OS
(i.e. the sound section of the control panel in windows)

Comment 5

17 years ago
So you mean bug 71123 has been fixed?

Which Windows sound event does it use?

Comment 6

17 years ago
Uses mailbeep

Comment 7

17 years ago
hmmm... well, it seems that Windows 95 retail (the only version of windows
without internet explorer pre-installed) does not support Mailbeep. It simply
aint in the list. :(
(Reporter)

Comment 8

17 years ago
The mail notification sound worked fine with the latest nightly build before
relase of milestone 0.95 (using the system sound of windows 2000 or windows xp),
it also works with the nightly build of October, 14th (the build after milestone
0.95), but it does not work with the milestone release 0.95, build 2001101117.
Is this correct, will there be a fixed 0.95 with acoustic mail notification?
marking worksforme (after reporters comment)

Reporter: There will be Mozilla 0.9.6 in ~12 days
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
verified.  no, 0.9.5 is done and there won't be any respins.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.