Closed Bug 992875 Opened 8 years ago Closed 8 years ago

The password for the sync account can be changed after Disconnecting the account

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 988446

People

(Reporter: phorea, Unassigned)

Details

(Whiteboard: DUPEME)

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0

Reproducible on Firefox 29 beta 5 (20140403132807), latest Aurora 30.0a2(20140406004002) and latest Nightly 31.0a1 (20140406030203) under Win 7 64-bit, Ubuntu 32-bit and Mac OSX 10.9.2.

Steps to reproduce:
1. Go to Tools -> Set up sync..
2. Click on Get started button
3. Sign in
4. Click on Manage button
5. Click on the Manage button from Options panel, Sync tab: the page https://accounts.firefox.com/settings opens in a new tab
6. Open Menu Panel, select the sync e-mail address
7. In Options panel, Sync tab, select "Disconnect.." and "Continue" in the dialog
8. On the tab left open at step 5 (Manage account), select "Change password"
9. Enter Old and New password and click "Change Password" - Password changed is displayed 
10. Sign in again - the new password is requested

Expected results:
User shouldn't be able to change the password after disconnecting.

Actual results:
The password can be changed, the settings page is not automatically refreshed.

Notes:
1. At step 7, the page about:account is refreshed
1. This issue is not a regression
"Disconnecting" in Firefox doesn't sign you out on accounts.firefox.com - that's a known issue. There are other bugs tracking similar issues.
Whiteboard: DUPEME
We can do better to differentiate the 'account manager' website from the about:accounts sign in pages.  Currently, the two look the same and can be confusing that they're really two disconnected application states.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 988446
You need to log in before you can comment on or make changes to this bug.