Closed Bug 992880 Opened 6 years ago Closed 6 years ago

Unable to change proxy settings via GUI

Categories

(Firefox :: Untriaged, defect)

31 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 991461

People

(Reporter: tleepa, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140405030204

Steps to reproduce:

Go to preferences - Advanced - Network - Connection Settings.
Proxy is set to "use system proxy settings" by default.
Change to whatever other option.
Click OK.
Enter Connection Settings again.


Actual results:

The configuration reverts to "use system proxy settings".
Every time.


Expected results:

The chosen option should be enabled instead of default "use system proxy settings".

The only way I can make changes stick is through about:config entries.
Tested on both x86 and x64 versions on Windows 7 x64. Builds v30 and v31.

Everything is working as expected in stable version (28.0).

I understand that it may not be a bug but a feature with some logic behind it but I was not able to find any information on this subject...
Hello Tomasz,

I have tried to replicate your problem, but have been unable to do so... everything reguarding the connection settings seems to be working...

I'm using Windows 7 x64, and my Mozilla is build v31
OK, I dug a little bit more and I have found out that this problem can be observed only when the preferences are edited "in content" (browser.preferences.inContent = true).
If I set it back to false and use the regular menu Tools -> Options and edit the preferences in the dialog window, the changes stick.
Are you using the in-content preferences in Firefox 31? (ie, they show up in a browser tab rather than as a separate window?)
Flags: needinfo?(tleepa)
Egh, somehow I missed comment #2, sorry.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Flags: needinfo?(tleepa)
Resolution: --- → DUPLICATE
Duplicate of bug: 991461
You need to log in before you can comment on or make changes to this bug.