Closed Bug 993298 Opened 8 years ago Closed 8 years ago

[Sora]FDN Device is not able to recognise wild characters

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, P1)

defect

Tracking

(tracking-b2g:backlog)

RESOLVED INVALID
tracking-b2g backlog

People

(Reporter: sync-1, Assigned: salva)

References

Details

(Keywords: feature, Whiteboard: [priority])

Attachments

(2 files)

5.36 MB, application/x-zip-compressed
Details
4.91 MB, text/plain
Details
Mozilla build ID:20140323004002
 
 Created an attachment (id=693343)
 2014-04-07 Log 1.zip
 
 [Telefonica][Spain] FDN Device is not able to recognise wild characters
 
 When FDN is enabled and a contact in the FDN list is added with wild characters (*, #) the device is not able to recognize them properly:
 
 In the log I have followed these steps:
 
 1) Insert SIM
 2) Enable FDN
 3) Create a contact in the FDN list with wild characters, for example:
 
 91490444*
 
 4) Try to make a phone callto this number 914904441
 
 5) As it matches with the FDN contact created it should allow to make the call but actually the device does not allow to make it stating that this number is not included in the FDN.
 
 Characters normally used as wild cards in FDN are: *, #
 
 
 Log: 2014-04-07 Log 1.zip
Attached file 2014-04-07 Log 1.zip
blocking-b2g: --- → 1.3?
Attached file the adb logcat
Hi -

According to the log:

04-07 11:50:22.433 D/use-Rlog/RLOG-RIL_QC_B2G(  292): Received message UNSOL_SIGNAL_STRENGTH
04-07 11:50:33.313 D/use-Rlog/RLOG-RIL_QC_B2G(  292): RILRequest Obtain
04-07 11:50:33.313 D/use-Rlog/RLOG-RIL_QC_B2G(  292): [SUB0] [0622]> DIAL 914904441 0
04-07 11:50:33.313 D/use-Rlog/RLOG-RIL_QC_B2G(  292): [SUB0] RIL Send
04-07 11:50:33.313 D/use-Rlog/RLOG-RIL_QC_B2G(  292): Received message CUSTOM_UNSOL_PHONE_STATE_CHANGED
04-07 11:50:33.313 E/RILQ    (  269): (0/269): RIL[0][main] get_ecc_property_name: ecc list name : ril.ecclist.
04-07 11:50:33.323 D/use-Rlog/RLOG-RIL_QC_B2G(  292): [SUB0] RIL ProcessResponse
04-07 11:50:33.323 D/use-Rlog/RLOG-RIL_QC_B2G(  292): [SUB0] RIL ProcessSolicitied
04-07 11:50:33.323 D/use-Rlog/RLOG-RIL_QC_B2G(  292): [SUB0] [0622]< DIAL fails by FdnCheckFailure(14)

The error seems returned from QCT RIL, might need QCT to check first.
Flags: needinfo?(anshulj)
Inder,

Can we please check if this is on the QC RIL?

QA,

Please check on Moz RIL.
Flags: needinfo?(ikumar)
Keywords: qawanted
Since wild characters are not yet supported in FFOS due to lack of Gaia support the wild characters are dropped when making a call.
Flags: needinfo?(anshulj)
Anshul provided the info so clearing ni.
Flags: needinfo?(ikumar)
Let me backlog this one for product to consider on the road map for upcoming releases.
blocking-b2g: 1.3? → backlog
Keywords: qawanted
Keywords: feature
Whiteboard: [priority]
Assignee: nobody → salva
(In reply to Anshul from comment #5)
> Since wild characters are not yet supported in FFOS due to lack of Gaia
> support the wild characters are dropped when making a call.

I don't understand what do you mean with lack of Gaia support. The settings application is not performing any check on the number entered, nor filtering it. I think the problem is in Gecko side. Maybe are you referring to some other thing?
Flags: needinfo?(anshulj)
Reporter, please file an SR so we can support you.
Flags: needinfo?(anshulj) → needinfo?(sync-1)
We are already resolved it, so please close it. Thanks
Flags: needinfo?(sync-1)
Given there were no Gaia / Gecko issue and per comment 10, marking as invalid
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.