Closed Bug 993378 Opened 7 years ago Closed 7 years ago

Add more languages to languages_dev.json to increase testing exposure

Categories

(Firefox OS Graveyard :: Gaia, defect)

defect
Not set
normal

Tracking

(tracking-b2g:backlog, b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
1.4 S6 (25apr)
tracking-b2g backlog
Tracking Status
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: Pike, Assigned: Pike)

References

Details

Attachments

(1 file)

We'd like to add more languages that are complete to the builds we test in QA, aka, to languages_dev.json.

This is for both master and 1.4.
There's not all that much we can actually do right now, due to the lack of git mirrors.

Also, this is much of bug 959406, which only ever landed on 1.3, but not on master at the time, and thus not in 1.4.
Depends on: 993513
Component: Gaia → Gaia::L10n
Gregor, please read component descriptions before moving bugs around. :L10n is about the js library, not about localizations of gaia.
Component: Gaia::L10n → Gaia
This adds a bunch of languages.

On _all, I'm adding bg and mk, which got dropped compared to 1.3.

On _dev, I'm adding 17 languages, but that's only 12 compared to 1.3, also due to that language update only landing on branch, and not master.

I'm skipping cy, eo, fy-NL, ga-IE, gd right now, I'll keep those for the flame.
Attachment #8405358 - Flags: review?(21)
Keywords: checkin-needed
Backlog - this helps for internal testing, but isn't a blocking issue for 1.4.
blocking-b2g: 1.4? → backlog
Master: https://github.com/mozilla-b2g/gaia/commit/bc71afe1c066c9e1b24a66e098b0e09acb6700a6
Status: NEW → RESOLVED
Closed: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 1.5 S1 (9may)
Comment on attachment 8405358 [details] [review]
add a bunch of languages that should get testing

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined:
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky):
[String changes made]:
Attachment #8405358 - Flags: approval-gaia-v1.4?(praghunath)
(verified on latest master)
Comment on attachment 8405358 [details] [review]
add a bunch of languages that should get testing

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: if this doesn't land, users won't have locales tested by QA
[Testing completed]:yes
[Risk to taking this patch] (and alternatives if risky):no risk
[String changes made]:none
Comment on attachment 8405358 [details] [review]
add a bunch of languages that should get testing

missed the boat on 4/11. My bad given that potential l10n work could be halted.

delphine> or else there will be 1.4 locales that won't have been tested
Attachment #8405358 - Flags: approval-gaia-v1.4?(praghunath) → approval-gaia-v1.4+
Target Milestone: 2.0 S1 (9may) → 1.4 S6 (25apr)
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.