Closed Bug 993406 Opened 7 years ago Closed 7 years ago

[Contacts][unit test] Follow up 909201: Add unit test to search view when a contacts change

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

x86
macOS
defect
Not set
normal

Tracking

(b2g-v2.0 fixed)

RESOLVED FIXED
1.4 S6 (25apr)
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: arcturus, Assigned: arcturus)

References

Details

Attachments

(1 file)

We didn't add unit test in bug 909201 for an easy way of a contributor to start helping with the project, but we should have them.

Take a look to patch proposed in bug 955972 to have an idea of how to do this.
See Also: → 909201
Assignee: nobody → francisco.jordano
Blocks: 909201
See Also: 909201
Attached file Pointer to PR 18176
Attachment #8404693 - Flags: review?(bkelly)
Flags: in-testsuite+
Comment on attachment 8404693 [details] [review]
Pointer to PR 18176

Overall looks good, but lets try to kill that |setTimeout()| if we can.  I think if we pass the callback through to the search update code we can avoid it.  What do you think?
Attachment #8404693 - Flags: review?(bkelly)
I though that, actually if you take a look to the code I already modified the order where the search update and the callback are called.

The problem is |updateSearchList| is asynchronous as well.

But definitely will explore that rather than left there the setTimeout (blame on me for even trying ;))
Comment on attachment 8404693 [details] [review]
Pointer to PR 18176

What about now?

;)
Attachment #8404693 - Flags: review?(bkelly)
Comment on attachment 8404693 [details] [review]
Pointer to PR 18176

r=me with fixes noted on github and green travis.  TBPL try build for bonus points. :-)  Looks like travis is running way behind today.
Attachment #8404693 - Flags: review?(bkelly) → review+
Thanks!

Comments addressed, will wait for travis green before merging.
Landed:

https://github.com/arcturus/gaia/commit/b58048b65305911fddfe386f75b49f831ba819fc
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S6 (25apr)
You need to log in before you can comment on or make changes to this bug.