If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Assertion at nsDocLoader.cpp line 1277, Crash

RESOLVED WORKSFORME

Status

()

Core
Document Navigation
--
critical
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: NilsE, Assigned: Adam Lock)

Tracking

({crash, stackwanted})

Trunk
Future
x86
Linux
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
This is my own CVS build at 2001/09/12, 07 UTC on RH 7.1.

After a lot of browsing, Mozilla finally asserts on http://www.msnbc.com/ and
segfaults. 

Crash is not reproducable. 

JS is switched off, I'm using junkbuster as local proxy for HTTP 1.0. I'm
tossing this to networking as that's my best guess as to where nsDocLoader belongs.

Console messages just before the crash:

WEBSHELL+ = 13
Disabling Quirk StyleSheet
WEBSHELL+ = 14
Disabling Quirk StyleSheet
Enabling Quirk StyleSheet
Disabling Quirk StyleSheet
Enabling Quirk StyleSheet
###!!! ASSERTION: win is null.  this happens [often on xlib builds].  see bug #7
9213: 'win', file /export/scratch/nils/src/mozilla/content/events/src/nsEventSta
teManager.cpp, line 571
###!!! Break: at file /export/scratch/nils/src/mozilla/content/events/src/nsEven
tStateManager.cpp, line 571
Document http://www.msnbc.com/ loaded successfully
###!!! ASSERTION: root element not in document: 'doc != nsnull', file /export/sc
ratch/nils/src/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp, line 1
524
###!!! Break: at file /export/scratch/nils/src/mozilla/content/xul/templates/src
/nsXULContentBuilder.cpp, line 1524
###!!! ASSERTION: root element not in document: 'doc != nsnull', file /export/sc
ratch/nils/src/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp, line 1
524
###!!! Break: at file /export/scratch/nils/src/mozilla/content/xul/templates/src
/nsXULContentBuilder.cpp, line 1524
###!!! ASSERTION: root element not in document: 'doc != nsnull', file /export/sc
ratch/nils/src/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp, line 1
524
###!!! Break: at file /export/scratch/nils/src/mozilla/content/xul/templates/src
/nsXULContentBuilder.cpp, line 1524
###!!! ASSERTION: root element not in document: 'doc != nsnull', file /export/sc
ratch/nils/src/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp, line 1
524
###!!! Break: at file /export/scratch/nils/src/mozilla/content/xul/templates/src
/nsXULContentBuilder.cpp, line 1524
###!!! ASSERTION: root element not in document: 'doc != nsnull', file /export/sc
ratch/nils/src/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp, line 1
524
###!!! Break: at file /export/scratch/nils/src/mozilla/content/xul/templates/src
/nsXULContentBuilder.cpp, line 1524
###!!! ASSERTION: root element not in document: 'doc != nsnull', file /export/sc
ratch/nils/src/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp, line 1
524
###!!! Break: at file /export/scratch/nils/src/mozilla/content/xul/templates/src
/nsXULContentBuilder.cpp, line 1524
###!!! ASSERTION: root element not in document: 'doc != nsnull', file /export/sc
ratch/nils/src/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp, line 1
524
###!!! Break: at file /export/scratch/nils/src/mozilla/content/xul/templates/src
/nsXULContentBuilder.cpp, line 1524
###!!! ASSERTION: root element not in document: 'doc != nsnull', file /export/sc
ratch/nils/src/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp, line 1
524
###!!! Break: at file /export/scratch/nils/src/mozilla/content/xul/templates/src
/nsXULContentBuilder.cpp, line 1524
###!!! ASSERTION: root element not in document: 'doc != nsnull', file /export/sc
ratch/nils/src/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp, line 1
524
###!!! Break: at file /export/scratch/nils/src/mozilla/content/xul/templates/src
/nsXULContentBuilder.cpp, line 1524
###!!! ASSERTION: root element not in document: 'doc != nsnull', file /export/sc
ratch/nils/src/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp, line 1
524
###!!! Break: at file /export/scratch/nils/src/mozilla/content/xul/templates/src
/nsXULContentBuilder.cpp, line 1524
###!!! ASSERTION: root element not in document: 'doc != nsnull', file /export/sc
ratch/nils/src/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp, line 1
524
###!!! Break: at file /export/scratch/nils/src/mozilla/content/xul/templates/src
/nsXULContentBuilder.cpp, line 1524
###!!! ASSERTION: root element not in document: 'doc != nsnull', file /export/sc
ratch/nils/src/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp, line 1
524
###!!! Break: at file /export/scratch/nils/src/mozilla/content/xul/templates/src
/nsXULContentBuilder.cpp, line 1524
###!!! ASSERTION: root element not in document: 'doc != nsnull', file /export/sc
ratch/nils/src/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp, line 1
524
###!!! Break: at file /export/scratch/nils/src/mozilla/content/xul/templates/src
/nsXULContentBuilder.cpp, line 1524
###!!! ASSERTION: root element not in document: 'doc != nsnull', file /export/sc
ratch/nils/src/mozilla/content/xul/templates/src/nsXULContentBuilder.cpp, line 1
524
###!!! Break: at file /export/scratch/nils/src/mozilla/content/xul/templates/src
/nsXULContentBuilder.cpp, line 1524
nsWidget::~nsWidget() of toplevel: 228 widgets still exist.
nsWidget::~nsWidget() of toplevel: 226 widgets still exist.
WEBSHELL- = 13
###!!! ASSERTION: Wrong Document Channel: 'request == mDocumentRequest', file /e
xport/scratch/nils/src/mozilla/uriloader/base/nsDocLoader.cpp, line 1277
###!!! Break: at file /export/scratch/nils/src/mozilla/uriloader/base/nsDocLoade
r.cpp, line 1277
###!!! ASSERTION: Wrong Document Channel: 'request == mDocumentRequest', file /e
xport/scratch/nils/src/mozilla/uriloader/base/nsDocLoader.cpp, line 1277
###!!! Break: at file /export/scratch/nils/src/mozilla/uriloader/base/nsDocLoade
r.cpp, line 1277
###!!! ASSERTION: Wrong Document Channel: 'request == mDocumentRequest', file /e
xport/scratch/nils/src/mozilla/uriloader/base/nsDocLoader.cpp, line 1277
###!!! Break: at file /export/scratch/nils/src/mozilla/uriloader/base/nsDocLoade
r.cpp, line 1277
/export/scratch/nils/src/mozilla/obj-opt/dist/bin/run-mozilla.sh: line 72:   648
 Segmentation fault      $prog ${1+"$@"}

Comment 1

16 years ago
Can you try this in gdb to get a stacktrace?
Severity: normal → critical
Keywords: crash, stackwanted
(Reporter)

Comment 2

16 years ago
Sorry, no. I'd have done so already if I new a way to reproduce this bug.
(Reporter)

Comment 3

16 years ago
s/new/knew/

Comment 4

16 years ago
docshell
Assignee: neeti → adamlock
Component: Networking → Embedding: Docshell
QA Contact: benc → adamlock
(Assignee)

Comment 5

16 years ago
Marking future
Target Milestone: --- → Future
(Assignee)

Comment 6

16 years ago
Have you seen this bug again since raising it?
(Reporter)

Comment 7

16 years ago
Seen it once again, but that's now weeks ago. Couldn't reproduce it anyway.
Maybe this should now be marked WORKSFORME.
(Assignee)

Comment 8

16 years ago
Okay, I'll do that but if you catch the problem in a recent build, please reopen. 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.