javascript and bookmarks works netscape and Ie5

VERIFIED FIXED

Status

()

Core
DOM: Core & HTML
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Stephen George, Assigned: jst)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
First I would like to say sorry if this has already been reported. I am a bear
of very little brain and could not work out how to search your bug page. When I
tried it hung for 20mins so I gave up.

Second this bug occures in redhat 7.1 mozzila and works fine with netscape and
IE5 The about page is Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; 0.7)
Gecko/20010316.

If the url is webpage.html the page loads fine and the javascript is run.
If the url is webpage.html#bookmark the page loads but the document is never
completed and in this case the page does not print. Here is webpage.html


<html>
<head> <title>Contractor Acounts web page</title><base target="_self">
<SCRIPT LANGUAGE="JavaScript">


<!-- Begin
function printPage() {
if (window.print) {
agree = confirm('OK to print now?');
if (agree) window.print();
   }
}
//  End -->

</script>

</head>
<BODY OnLoad="printPage()">

<a name="bookmark">

This is a test

</body>
</html>
(Assignee)

Comment 1

17 years ago
Do you see the throbber not stopping when you say the page never completes? Or
do you just see that the onload handler is never called?
> Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; 0.7) Gecko/20010316.

That is a 6 month old copy of Mozilla.  MANY things have been fixed since then.
 Can you please download a new version and test that out?
http://ftp.mozilla.org/pub/mozilla/nightly/latest/

Comment 3

16 years ago
prints the page with build 2001-09-21-05. marking resolved
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Keywords: vtrunk
Resolution: --- → FIXED

Comment 4

16 years ago
Created attachment 50556 [details]
testcase.load url and append with #bookmark

Comment 5

16 years ago
verified fixed. reported please reopen if you still see this problem
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: DOM: Core → DOM: Core & HTML
QA Contact: stummala → general
You need to log in before you can comment on or make changes to this bug.