Closed Bug 993832 Opened 6 years ago Closed 6 years ago

wrong multi-res resource file name

Categories

(Firefox OS Graveyard :: Gaia::Build, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
1.4 S6 (25apr)

People

(Reporter: gasolin, Assigned: gasolin)

Details

Attachments

(1 file)

Run script and found some errata

apps/homescreen/everything.me/images/Wallpaper@2.25.png
apps/system/style/net_error/iframe_settings_icon@1.5.png
apps/wallpaper/style/icons/64/Wallpaper@2.25.png
Assignee: nobody → gasolin
Status: NEW → ASSIGNED
With this rename fix I can generate multiple resolution table

http://gasolin.github.io/gaia/

with this script https://gist.github.com/gasolin/6052727

Do you think it's proper to check this script into tools/ folder ?
Attachment #8403741 - Flags: review?(yurenju.mozilla)
Component: Gaia → Gaia::Build
Comment on attachment 8403741 [details] [review]
pull request redirect to github

r=yurenju.

for landing the tool into gaia, I feel it should be a make rule to check what kind if resolution missed, like:

DEV_PIXELS="1,1.5,2.5" make check-images

and show what files miss in console output.
Attachment #8403741 - Flags: review?(yurenju.mozilla) → review+
Currently the script walk through all image and detect pixels between @...x . 
It's a pretty quick scan so I think it's not worth to specify a certain pixel size.

Does gaia still accept python script?
merged https://github.com/gasolin/gaia/commit/a4a0895fd5eac44405e3cecafe2fa129dae5577a

thanks!
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
sorry had to backout/revert this change for test failures like https://tbpl.mozilla.org/php/getParsedLog.php?id=37738927&tree=B2g-Inbound - seems they failed on OS X and not Linux, thats why travis in this case was green
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Hi Gasolin, please run try server before you land it again, thanks
Flags: needinfo?(gasolin)
I think it's not possible to catch multi-res resource only bug on TBPL since we did not have any test for this case yet...

Let's run try server again
https://tbpl.mozilla.org/?tree=Try&rev=046b7d595200
Flags: needinfo?(gasolin)
run again to prevent non-related keyboard https://tbpl.mozilla.org/?tree=Try&rev=1b793e6e7fc7
got same result https://tbpl.mozilla.org/?tree=Try&rev=493c1b137b81

compare to master https://tbpl.mozilla.org/?tree=Try&rev=6b101b2f9ac5

merged https://github.com/mozilla-b2g/gaia/commit/9ce3fa58b57c5665a99dce2003e7b03a0b284770
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Thanks Carsten and Rayn to address the issue.

pass try server https://tbpl.mozilla.org/?tree=Try&rev=9cd2d7076713


After some time wasting survey, the root cause is the wallpaper@2.25x.png in e.me is not real image but a path shortcut, which is really a dark magic -__-
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S6 (25apr)
You need to log in before you can comment on or make changes to this bug.