Closed Bug 993849 Opened 6 years ago Closed 6 years ago

[Tarako][Bluetooth] No device found while a user searching device in BT headset connected state.

Categories

(Firefox OS Graveyard :: Vendcom, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3T affected)

RESOLVED WONTFIX
Tracking Status
b2g-v1.3T --- affected

People

(Reporter: iliu, Assigned: xinhe.yan)

Details

(Whiteboard: [POVB])

This happens on Tarako.

STR:
1. Pair a BT headset and let it in connected state.
2. tap 'Search for devices' button.

Expect result:
Should find some devices.

Actual result:
No device found.

======== log ========
Gaia does not received onDeviceFound() callback while a user click "Search for devices" button in BT headset connected state. So there is no log here.
Hi Eric,

I make sure that Gaia does not received onDeviceFound() callback while a user click "Search for devices" button in BT headset connected state.

Gaia register callback function "defaultAdapter.ondevicefound" in 
https://github.com/mozilla-b2g/gaia/blob/v1.3t/apps/settings/js/bluetooth.js#L60

And the onDeviceFound() function be called in
https://github.com/mozilla-b2g/gaia/blob/v1.3t/apps/settings/js/bluetooth.js#L568

I would like to suggest Gecko::Bluetooth for investigation the situation.
Ian, which BT headset is this?
Also which build are you on?
Flags: needinfo?(iliu)
Naoki,

The headset is JABRA TALK. And I will try it again with latest build version with different headset module since my build updated. I'm requesting other BT headset module from partner.
Flags: needinfo?(iliu)
I can reproduce. This is an issue because of custom bt-stack or the capability of bt firmware.

When there is a bt profile-level connection, I try to start inquiry but got an InquiryComplete event replied immediately, which indicates that the inquiry process has completed.

< HCI Command: Inquiry (0x01|0x0001) plen 5
    lap 0x9e8b33 len 8 num 0
> HCI Event: Command Status (0x0f) plen 4
    Inquiry (0x01|0x0001) status 0x00 ncmd 1
> HCI Event: Inquiry Complete (0x01) plen 1
    status 0x00

Steven, could you assist with passing this issue to partner to confirm what I observed?
Flags: needinfo?(styang)
(In reply to Ian Liu [:ianliu] from comment #3)
> Naoki,
> 
> The headset is JABRA TALK. And I will try it again with latest build version
> with different headset module since my build updated. I'm requesting other
> BT headset module from partner.

Ian, I don't think this is an IOT issue. So I think you don't need find another device to do further test. Thanks for reporting.
James,could you find someone to help?
Flags: needinfo?(styang) → needinfo?(james.zhang)
Loop Xinhe
Assignee: nobody → xinhe.yan
Flags: needinfo?(james.zhang)
Tarako use our trout bt chip. It only support one link. So can not search after connected a2dp headset.
Component: Bluetooth → Vendcom
Whiteboard: [POVB]
(In reply to Xinhe Yan from comment #8)
> Tarako use our trout bt chip. It only support one link. So can not search
> after connected a2dp headset.

Thanks for quick response. :)
This bug will not fix on Tarako.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.