Closed Bug 993932 Opened 6 years ago Closed 6 years ago

TART regression from bug 986324

Categories

(Firefox :: Theme, defect)

All
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 31
Tracking Status
firefox29 --- fixed
firefox30 --- fixed
firefox31 --- fixed

People

(Reporter: dao, Assigned: mikedeboer)

References

Details

(Keywords: perf, Whiteboard: [Australis:P2][talos_regression][qa-])

Attachments

(1 file)

See bug 986324 comment #25.

I think this might be due to the border-color transition.
Flags: needinfo?(mdeboer)
Blocks: 986324
Yes, this most probably IS about the newly introduced border-color transistion.

Of course, I'll back that up and confirm this by pushing some try-runs.

I don't think introducing a .14 regression on TART is acceptable against keeping a transition that is hardly noticeable... right?
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
Flags: needinfo?(mdeboer)
Flags: needinfo?(jmaher)
Flags: needinfo?(dao)
Yes, I think we'll want to remove the transition.
Flags: needinfo?(dao)
Flags: needinfo?(jmaher)
The comparison table shows a solid .12 and .14 win on TART for Windows 7 and 8, respectively.

Next up: patch to remove transition for realz.
Attachment #8404208 - Flags: review?(dao) → review+
Thanks!

Pushed to fx-team as: https://hg.mozilla.org/integration/fx-team/rev/6c37a8480f1b
Whiteboard: [talos_regression] → [Australis:P2][talos_regression][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/6c37a8480f1b
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P2][talos_regression][fixed-in-fx-team] → [Australis:P2][talos_regression]
Target Milestone: --- → Firefox 31
The original patch was uplifted. Mike, can you request approval to uplift this fix as well? If we're quick, it might still make today's beta. Thanks!
Flags: needinfo?(mdeboer)
Comment on attachment 8404208 [details] [diff] [review]
Patch v1: remove border-color transition

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 986324
User impact if declined: This will make our talos tests on Aurora and Beta happy.
Testing completed (on m-c, etc.): landed on m-c
Risk to taking this patch (and alternatives if risky): very low.
String or IDL/UUID changes made by this patch: n/a.
Attachment #8404208 - Flags: approval-mozilla-beta?
Attachment #8404208 - Flags: approval-mozilla-aurora?
Flags: needinfo?(mdeboer)
Attachment #8404208 - Flags: approval-mozilla-beta?
Attachment #8404208 - Flags: approval-mozilla-beta+
Attachment #8404208 - Flags: approval-mozilla-aurora?
Attachment #8404208 - Flags: approval-mozilla-aurora+
Whiteboard: [Australis:P2][talos_regression] → [Australis:P2][talos_regression][qa-]
You need to log in before you can comment on or make changes to this bug.