Long videos (with Vorbis audio) display impossible values for buffered ranges.

RESOLVED DUPLICATE of bug 739094

Status

()

defect
RESOLVED DUPLICATE of bug 739094
5 years ago
5 years ago

People

(Reporter: emujagic, Unassigned)

Tracking

Trunk
x86_64
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20140317233501

Steps to reproduce:

Create small web page with video (video/webm) of a longer duration and (as my tests show) with vorbis audio. Read buffered ranges.

Or go to: http://centrcam.com/firefoxtest2/


Actual results:

Table displaying buffered ranges contains negative numbers.


Expected results:

Buffered attribute returns TimeRanges objects which using start() and end() methods returns seconds for specified object index.

As file buffers this number returned by end() should get larger and indeed it does but starting from start() returned number.

I thing these numbers need to be nonnegative, or am I doing something wrong?
Alias: neg-buff-range-nums
Summary: long video with vorbis audio display impossible values for buffered range → Long videos (havig vorbis audio) display impossible values for buffered ranges.
OS: Linux → All
Reproduced on latest Nightly (20140408030205) under Win 7, 64-bit. Not setting as new yet as this may be duplicate of bug 616292.
Component: Untriaged → Video/Audio
Product: Firefox → Core
MediaDecoderStateMachine.cpp:2563 does if(startTime != 0) ... checking. If we replace it with >= 0 then we get expected behaviour. However, this startTime value comes from: MediaDecoderReader::FindStartTime() and should be further investigated.
I think there is a unit mismatch somewhere. The start time here is 3000, and the buffer.start(0) is -3000, that can't be a coincidence.
Flags: needinfo?(kinetik)
(In reply to Petruta Rasa [QA] [:petruta] from comment #1)
> Not setting as new yet as this may be duplicate of bug 616292.

Doesn't seem to be related.
Alias: neg-buff-range-nums
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Long videos (havig vorbis audio) display impossible values for buffered ranges. → Long videos (with Vorbis audio) display impossible values for buffered ranges.
This is bug 739094, see bug 739094 comment 4 for details.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(kinetik)
Resolution: --- → DUPLICATE
Duplicate of bug: 739094
Wow, I fat-fingered the bug number in the commit message. That belongs in bug 993097.
Assignee: hurley → nobody
You need to log in before you can comment on or make changes to this bug.