Closed Bug 993985 Opened 5 years ago Closed 5 years ago

Tooltip broken in Developer Toolbar

Categories

(DevTools Graveyard :: Graphic Commandline and Toolbar, defect)

30 Branch
x86_64
Windows 7
defect
Not set

Tracking

(firefox29 unaffected, firefox30+ verified, firefox31+ verified)

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 --- unaffected
firefox30 + verified
firefox31 + verified

People

(Reporter: alice0775, Assigned: jwalker)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image 無題.png
Steps To Reproduce:
1. Open Developer Toolbar (Shift + F2)
2. Type s and press Enter

Actual Results:
Empty tooltip pops up

Expected Results:
The tooltip should not empty.


Regression pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=82508f3c2088&tochange=c3ce3b51c881

Regressed by:
	02ad58b18823	Joe Walker — Bug 933727 - Split gcli.jsm and use JS directly from gcli project; r=mratcliffe * * * Bug 933727 - Update Developer Toolbar to use promises and split out GCLI; r=mratcliffe * * * Bug 933727 - Update GCLI tests to use Task.spawn; r=mratcliffe * * * Bug 933727 - Update the Inspector to use split out GCLI; r=pbrosset * * * Bug 933727 - Update style editor to use split out GCLI; r=harth * * * Bug 933727 - Update Debugger to use split out GCLI; r=past * * * Bug 933727 - Update Profiler/Tilt/Scratchpad to use split out GCLI; r=valueof
Joe, could you have a look at this?
Flags: needinfo?(jwalker)
It's on my list
Assignee: nobody → jwalker
Flags: needinfo?(jwalker)
We were using OS.Path.dirname, but that (reasonably) assumes '\' on windows, and when you're manipulating URL segments, you don't want that, so this uses a dirname based on '/' everywhere.

Also it adds a couple of console.errors to be more explicit about the breakage for the future.
Attachment #8408314 - Flags: review?(mratcliffe)
Attachment #8408314 - Flags: review?(mratcliffe) → review+
https://hg.mozilla.org/mozilla-central/rev/45d9d4a20b13
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Joe, Would this also need uplift since its marked affecting 30?
Flags: needinfo?(jwalker)
Comment on attachment 8408314 [details] [diff] [review]
0001-wintip-993985.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 933727
User impact if declined: Developer toolbar tooltips are broken
Testing completed (on m-c, etc.): on m-c for a week

Risk to taking this patch (and alternatives if risky): Low. The change to host.js (which is the largest chunk) is very well tested code (we're effectively using the unix dirname on windows). The additions to menu.js are to better diagnose the problem, so this is mostly a 1 line change.

String or IDL/UUID changes made by this patch: None
Attachment #8408314 - Flags: approval-mozilla-aurora?
Flags: needinfo?(jwalker)
(In reply to Benjamin Kerensa [:bkerensa] from comment #7)
> Joe, Would this also need uplift since its marked affecting 30?

Yes, thanks.
Attachment #8408314 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
QA Whiteboard: [good first verify]
Hi,

I was able to reproduce it on Windows 7 x86_64 on 31.0a1 (2014-03-26) and I can confirm it's fixed on:

- latest Beta Firefox/30.0 ID:201404201115057
- latest Aurora 31.0a2 (2014-05-22)

Cheers,
Francesca
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.