ibm.com - Page displayed incorrectly due to server not handling Mozilla user agent

VERIFIED FIXED

Status

P1
normal
VERIFIED FIXED
18 years ago
4 years ago

People

(Reporter: mike, Assigned: bc)

Tracking

Details

(Whiteboard: [USER-AGENT], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4+)
Gecko/20010912
BuildID:    2001091203

All thats shown when a support flash is selected is the following:-
<html><body></body></html>

Works fine in ie & opera.

Reproducible: Always
Steps to Reproduce:
1.Goto http://www.ibm.com/software/support/
2.Select a support flash
3.

Actual Results:  Displays <html><body></body></html> rather than the correct page.

Expected Results:  Shown the correct page details. 

IE only just manages to do this useing a totally inappropriate font size. So far
only opera has displayed the page correctly.

Comment 1

18 years ago
Confirming.  I see the same thing with build 2001091003, but it works correctly
in NS 4.x.  Since there is some JS code in the page source, I tried turning JS
on and off, but that didn't make any difference.
Status: UNCONFIRMED → NEW
Ever confirmed: true
->layout? reassign as needed.
Assignee: pchen → attinasi
Component: XP Apps → Layout
QA Contact: sairuh → petersen

Comment 3

18 years ago
Works fine in Netscape 6.1 - The server is browser-sniffing and does not know
what to do with Mozilla... 

I tried the following URL (the first support flash link):
http://www-1.ibm.com/servlet/support/manager?rs=203&rt=0&org=SW&doc=1040614

I saved the page from Netscape6.1 to a local file, it loads fine (I'll attach)

over to evangelism.

Comment 4

18 years ago
Created attachment 49218 [details]
Pages as saved from Netscape 6.1 (added <base href> as well) - Works fine in Mozilla

Comment 5

18 years ago
The server is sniffing the browser (presumably) and is not handling Mozilla.
Pages saved from Netscape6.1 (or IE6) loads fine in Mozilla. Over to evang.
Assignee: attinasi → bclary
Component: Layout → US English
Product: Browser → Tech Evangelism
QA Contact: petersen → zach
Summary: Page displayed incorrectly → Page displayed incorrectly due to server not handling Mozilla user agent
Version: other → unspecified
(Assignee)

Updated

18 years ago
Priority: -- → P1
Summary: Page displayed incorrectly due to server not handling Mozilla user agent → ibm.com - Page displayed incorrectly due to server not handling Mozilla user agent
Whiteboard: [USER-AGENT]
(Assignee)

Comment 6

17 years ago
wfm in Mozilla 20011030/win2k. -> fixed. 
the page has other CSS related issues, but the originally reported problem is fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 7

17 years ago
Verified
2002030208/WinXP
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.