Closed Bug 994083 Opened 6 years ago Closed 6 years ago

Investigate why browser_989289_force_icons_mode_attribute.js leaks on Aurora

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 31
Tracking Status
firefox30 --- fixed
firefox31 --- fixed

People

(Reporter: ttaubert, Assigned: ttaubert)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file)

The test has been disabled on Aurora:

https://hg.mozilla.org/releases/mozilla-aurora/rev/4f6268f94b1d

Due to to leaks like this:

https://tbpl.mozilla.org/php/getParsedLog.php?id=37477352&tree=Mozilla-Aurora

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser_635418.js | leaked until shutdown [nsGlobalWindow #7109 chrome://browser/content/tabview.html]
TEST-UNEXPECTED-FAIL | browser/components/sessionstore/test/browser_635418.js | leaked 2 window(s) until shutdown [url = chrome://browser/content/tabview.html]
I can reproduce this locally and I'm pretty sure this is caused by browser_635418.js creating the TabView window and browser_tabview_bug626455.js "leaking" it as that is the last test before shutdown and it doesn't clean up properly.

Aurora try push:

https://tbpl.mozilla.org/?tree=Try&rev=940fbe5b3aa5
Assignee: nobody → ttaubert
Status: NEW → ASSIGNED
Attachment #8404009 - Flags: review?(mdeboer)
Comment on attachment 8404009 [details] [diff] [review]
0001-Bug-994083-Ensure-that-browser_tabview_bug626455.js-.patch

Review of attachment 8404009 [details] [diff] [review]:
-----------------------------------------------------------------

Well, this fixes the leak for sure and the code additions are good. Can you explain why this manifests on Aurora and not fx-team, for example?
Attachment #8404009 - Flags: review?(mdeboer) → review+
(In reply to Mike de Boer [:mikedeboer] from comment #3)
> Can you
> explain why this manifests on Aurora and not fx-team, for example?

mconley added a new test to Aurora that changed the set of chunks we run mochitest-bc1,2,3 in. Now that browser_tabview_bug626455.js was the last of the bc1 chunk it accused other test of leaking by not cleaning up properly. The leak detection mechanism sees that browser_635418.js creates Panorama's nsGlobalWindow and if that doesn't go away on shutdown then it assumes the test leaks.
It doesn't leak on fx-team because we have different sets of m-bc chunks there. Fun.
FWIW, this can land on Aurora a=test-only once it's green on trunk.

Also, is anybody auditing other tests for similar issues? I'm afraid we're going to be one chunking change away from hitting this scenario again in the future, and I'm sure people have cribbed old tests when writing new ones.
https://hg.mozilla.org/mozilla-central/rev/478e745619d9
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 31
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.