Closed Bug 994263 Opened 6 years ago Closed 6 years ago

Removing GC'd nodes in the Web Audio Editor frontend

Categories

(DevTools Graveyard :: Web Audio Editor, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 33

People

(Reporter: jsantell, Assigned: jsantell)

References

Details

Attachments

(1 file, 3 obsolete files)

For AudioNode#disconnect() cases, not garbage collecting cases.
Correcting myself, this is for when
Depends on: 980506
Correcting myself, this is for when a node gets GC'd as there's no way to explicitly delete nodes, and disconnected nodes should still remain in the params and graph view.
No longer depends on: 980506
Component: Developer Tools → Developer Tools: Web Audio Editor
Depends on: 1008497
No longer depends on: 1008497
Depends on: 980506
Duplicate of this bug: 1008497
Summary: Handle explicitly removing audio nodes in Web Audio Editor → Removing GC'd nodes in the Web Audio Editor frontend
No longer blocks: webaudioeditorv1
WIP patch, dependent on back end server events (bug 980506)
Assignee: nobody → jsantell
Status: NEW → ASSIGNED
During the tests, waits a few seconds for GC, even after calling the force cycle collection/GC -- wonder if this will be an issue.
Attachment #8437135 - Attachment is obsolete: true
Attachment #8444766 - Flags: review?(vporof)
Attachment #8444766 - Attachment is obsolete: true
Attachment #8444766 - Flags: review?(vporof)
Attachment #8444855 - Flags: review?(vporof)
Comment on attachment 8444855 [details] [diff] [review]
994263-hide-destroy-nodes-in-wae-front-end.patch

Review of attachment 8444855 [details] [diff] [review]:
-----------------------------------------------------------------

Clean as always.
Attachment #8444855 - Flags: review?(vporof) → review+
https://hg.mozilla.org/integration/fx-team/rev/b043afd9261f
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/b043afd9261f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 33
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.