[DOCTYPE?] Strange behavior of www.penguinista.org

RESOLVED DUPLICATE of bug 98977

Status

()

Core
Layout
--
minor
RESOLVED DUPLICATE of bug 98977
17 years ago
17 years ago

People

(Reporter: Luca Fasolo, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
- Open the main page of http://www.penguinista.org/
 - Click on "Posted on ..." of a news
 - The page now is bigger than the browser window, with the text of the news 
   on the right.

Mozilla build: 2001091203, Windows NT
This doesn't happen with IE5

Comment 1

17 years ago
"Posted on" is not a link. The date-links next to "Posted on" WFM on linux CVS.

Updated

17 years ago
Assignee: asa → attinasi
Component: Browser-General → Layout
QA Contact: doronr → petersen

Comment 2

17 years ago
Got priavte mail from reporter: it's indeed the date links he refers to. Layout
component untill further - i think this is a dup..

Comment 3

17 years ago
confirmed win2000 build 2001091203

The page seems to create its content dynamically and, when the troublesome link
is clicked, the page that is loaded contains some code where the other page
contains content such as dates and stuff. Compare the source around the part
that says "you will be assimilated".
The code is mostly commented out, but it could be appearing instead of a closing
</td> or </tr> or something, which might cause the observed behaviour.
If it is a dup, I can't think what to search for.

Comment 4

17 years ago
Seeing this on Build 2001091203 Win98SE too. 
Broken URL:
http://www.penguinista.org/cgi-bin/article?byDate=Thursday%20September%2013,%202001

I'll take a look at the HTML source and see if it's a problem there, otherwise
I'll work on a testcase.

Comment 5

17 years ago
Strange. Take out the 
<!doctype html public "-//w3c//dtd html 4.0 transitional//en">
line from the HTML and everything works fine.

Any ideas anyone?

Comment 6

17 years ago
Found the problem (I think). Towards the start of the HTML, there are a couple
of comment tags that are never closed. Seems Moz and IE are deciding to close
them at different places. Stripping all the comments from the file also makes it
render fine.

I'd stay this is a problem with the HTML code, not Moz. (Actually, it's most
likely a problem with the server, because there were a lot of SSI-style commands
in the HTML source. But it's the same result to us - Broken HTML)
(Assignee)

Comment 7

17 years ago
I think this is a doctype parsing problem. Removing the doctype fixes it, but
switching the layout mode in Viewer does not. CC'ind dbaron since I think he has
been working on this problem...
Summary: Strange behavior of www.penguinista.org → [DOCTYPE?] Strange behavior of www.penguinista.org
The latest patch on bug 98977 should fix this.  (I'm just waiting for review on
that patch.)

*** This bug has been marked as a duplicate of 98977 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.