Won't Save from Composer (comment)

RESOLVED FIXED

Status

SeaMonkey
Composer
RESOLVED FIXED
17 years ago
13 years ago

People

(Reporter: Peter Jones, Assigned: Kathleen Brade)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Mozilla Build ID 2001080110

Steps to reproduce:
1. Open attachment (CPPA2) in Compositor (Mouse Button 2 and Edit)
2. Click HTML button to display HTML text
3. Place cursor as end of line containing "4test4", along with comment start (<!--)
4. Delete with backspace key until line changes
5. In File menu, try to Save As.

Result: File menu half changes, then Compositor doesn't react to KB or mouse.
DrWatson says "nothing unusual". On return to Compositor, window is completely
empty.

Expected Result: File save should have taken place.

This is a simplification. I actually discovered this problem attempting to use
the Browse button in Compositor.
Compositor is for rendering, not the same as the HTML Composer.

->Editor.
Assignee: kmcclusk → kin
Component: Compositor → Editor: Composer
QA Contact: petersen → sujay
(Assignee)

Comment 2

17 years ago
Reporter--please attach example file mentioned in steps.
-->Syd
Assignee: kin → syd
Summary: Won't Save from Compositor → Won't Save from Composer

Comment 3

17 years ago
Reporter - you are using a very old build - try and reporduce with a newer
build, downloadable from: http://ftp.mozilla.org/pub/mozilla/nightly/latest/
(Reporter)

Comment 4

17 years ago
Created attachment 49382 [details]
HTML file that won't Save As after <!-- comment-starts are deleted
(Reporter)

Comment 5

17 years ago
Responding to: ------- Additional Comments From brade@netscape.com 2001-09-13
07:55 -------
Done.

Responding to: ------- Additional Comments From Cormac F 2001-09-13 08:52
-------Done. I am now using Build 2001091043

Here are some new steps that are easier to "dance":
0. Download attachment
1 [details] [diff] [review]. Start Mozilla Navigator
2. Open attachment in Navigator
3. File/Edit
4. Display HTML text
5. Delete comment follwing the "test" message that had appeared at the end of
the page in Step 2.
6. Attempt to Save As.

Result:
1. Top of browser window is echoed half an inch below.
2. File save menu appears 15 sec later, on a 300 MHz processor with 64M memory;
   File menu appears normal.

Expected result:
File Save menu should appear almost immediately, with no disturbance to File menu.

I said earlier that this report was a simplification. Note that the attached
file contains several "test" comment starts. If I delete them all in Step 5, the
incorrect File menu stays up for at least 15 min. I observed occasional disk
activity, probably but not certainly related to Mozilla. At that point, I
terminated with CTRL-ALT-DEL and End Task.

While doing the above, I also tried clicking on Debug/Start Log while in
Composer and Debug Stop Log after deleting the first test comment and getting to
the File Save menu. But when I search for files modified "today" with Find File,
I did not
find any log files to send you.


Comment 6

17 years ago
Confirming that the several <!-- 's caused my moz to pause for approx 5 seconds
on PII350mhz 128M.  2001092503.  The pause occured every time the page was
rendered (every time I switched from HTML view back to page view.)  However,
despite the slowdown I was still able to edit and save the file.

Comment 7

17 years ago
On an 800Mhz machine I was locked out for about a minute.

Holey moley.
Whiteboard: EDITORBASE
Target Milestone: --- → mozilla0.9.6

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 8

16 years ago
Reassigning to Kathy since she is doing editor save changes. 
Assignee: syd → brade
Status: ASSIGNED → NEW
Target Milestone: mozilla0.9.6 → mozilla0.9.8
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.8 → mozilla0.9.9
(Assignee)

Comment 9

16 years ago
removing EDITORBASE per meeting
Summary: Won't Save from Composer → Won't Save from Composer (comment)
Whiteboard: EDITORBASE
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Keywords: nsbeta1+
(Assignee)

Comment 10

16 years ago
is this still a bug?  can someone retest?
Target Milestone: mozilla0.9.9 → mozilla1.0

Comment 11

16 years ago
Peter, please retest this and let us know if its still not working for you...

thanks.

Comment 12

16 years ago
Please update this bug with an [adt1] - [adt3] impact rating (or take it off the
list if it doesn't even rate adt3.)  Thanks!

Updated

16 years ago
Keywords: nsbeta1+ → nsbeta1

Updated

16 years ago
Target Milestone: mozilla1.0 → mozilla1.1alpha

Updated

16 years ago
Keywords: nsbeta1 → nsbeta1-
(Reporter)

Comment 13

16 years ago
Tested the procedure on the first attachment, deleted from "4test4" to the
"/body" tag, not inclusive. Worked fine with Build 2002031104. I would say the
bug is FIXED.
(Assignee)

Comment 14

16 years ago
resolving fixed per bug reporter
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Target Milestone: mozilla1.1alpha → ---
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.