[Sora][WIFI] The return button display error in wifi page

RESOLVED FIXED in 2.0 S1 (9may)

Status

defect
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sync-1, Assigned: eragonj)

Tracking

({regression})

unspecified
2.0 S1 (9may)

Firefox Tracking Flags

(blocking-b2g:1.4+, b2g-v1.4 fixed, b2g-v2.0 fixed)

Details

(Whiteboard: [ETA:5/9][p=2])

Attachments

(4 attachments, 2 obsolete attachments)

Reporter

Description

5 years ago
Firefox OS v1.3
 Mozilla build ID:20140323004002
 
 +++ This bug was initially created as a clone of Bug #640662 +++
 Created an attachment (id=695902)
 PIC
 
 DEFECT DESCRIPTION:
 The return button display error in wifi page
 
 REPRODUCING PROCEDURES:
 1.Open wifi from notification bar
 2.Enter wifi page
 3.The return button display "X",and click it have no response->KO
 
 EXPECTED BEHAVIOUR:
 The return button display normal
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 mid
 REPRODUCING RATE:
 5/5
 For FT PR, Please list reference mobile's behavior:
 Bettle Lite FF is OK
 ++++++++++ end of initial bug #640662 description ++++++++++
 
 		
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:5/5
 
  For FT PR, Please list reference mobile's behavior:
Reporter

Comment 1

5 years ago
Posted image PIC
Can someone confirm this on the Moz side?
Keywords: qawanted, regression

Updated

5 years ago
blocking-b2g: --- → 1.3?

Comment 3

5 years ago
(In reply to Jason Smith [:jsmith] from comment #2)
> Can someone confirm this on the Moz side?

I am unable to reproduce this issue on the latest 1.3 and 1.5 builds using the Buri and Open C. Each time I enter the WiFi menu through the notification bar, the back button is '<' and not 'X'. Also, the STR seems to indicate they can get to the WiFi menu directly where I have to go through the Settings menu first to get to the WiFi menu.
QA Contact: mvaughan

Comment 4

5 years ago
(In reply to Matthew Vaughan from comment #3)
> (In reply to Jason Smith [:jsmith] from comment #2)
> > Can someone confirm this on the Moz side?
> 
> I am unable to reproduce this issue on the latest 1.3 and 1.5 builds using
> the Buri and Open C. Each time I enter the WiFi menu through the
> notification bar, the back button is '<' and not 'X'. Also, the STR seems to
> indicate they can get to the WiFi menu directly where I have to go through
> the Settings menu first to get to the WiFi menu.

Please ignore the above comment... 

After further testing, I realized that I had to disable and then re-enable the WiFi within the notification area first.

In 1.3, this issue does reproduce. The 'X' appears and does nothing the first time I tap it. When I tap it a second time, it takes me back to the Settings menu.

In 1.4, the 'X' button is present but when I tap it, it takes me back to an empty Homescreen. 

In Master, there is no icon for the button but when I tap it, it takes me back to an empty and dimmed Homescreen.
Keywords: qawanted

Comment 5

5 years ago
(In reply to Matthew Vaughan from comment #4)
> In 1.3, this issue does reproduce. The 'X' appears and does nothing the
> first time I tap it. When I tap it a second time, it takes me back to the
> Settings menu.
> 
> In 1.4, the 'X' button is present but when I tap it, it takes me back to an
> empty Homescreen. 
> 
> In Master, there is no icon for the button but when I tap it, it takes me
> back to an empty and dimmed Homescreen.

I tested the 04/12/14 1.3, and the 04/14/14 1.4 and Master builds using a Buri. I also tested the 04/14/14 Open C 1.3 build using an Open C.

Comment 6

5 years ago
If click x button twice, there is chance to show blank screen and need to kill settings app.
QAWanted,

Please check if Comment 6 is reproducible. Check for 1.3 and 1.4

Comment 8

5 years ago
(In reply to Preeti Raghunath(:Preeti) from comment #7)
> QAWanted,
> 
> Please check if Comment 6 is reproducible. Check for 1.3 and 1.4

I am not able to reproduce what Jack stated in comment 6 on the 04/14/14 1.3 build on a Buri after ~20 attempts. Tapping the 'X' the first time does nothing but highlight the button (as shown in the attached PIC). Tapping it a second time takes me back to the Settings menu.

Device: Buri v1.3 MOZ RIL
BuildID: 20140414004002
Gaia: 8b92c56267fe50772095f1f25d6cc1f9c9966eb4
Gecko: 3e26908fca71
Version: 28.0
Firmware Version: v1.2-device.cfg

In 1.4, I will be taken back to an empty Homescreen after I tap the 'X' button once. I can recover by tapping the Home button, or long tapping the Home button and either re-enter or close the WiFi menu. 

Device: Buri v1.4 MOZ RIL
BuildID: 20140415000202
Gaia: c8f916c8569f6ee652237fd10ac925e08cd3d9bc
Gecko: f14047fa8d63
Version: 30.0a2
Firmware Version: v1.2-device.cfg
Keywords: qawanted
blocking-b2g: 1.3? → 1.4+
Arthur, can you reassign?
Flags: needinfo?(arthur.chen)

Comment 10

5 years ago
NIGHTLY (RIL):

This looks to be a gaia issue...

last working gaia/first broken gecko = NO REPRO
Gaia: 31808a29cfcffa584b6a88b4f1e515387f485a1b
Gecko: 526e12792fc8

first broken gaia/last working gecko = REPRO
Gaia: 324c467fc6b202fd09efe4b16cd83960fd2901eb
Gecko: 8648aa476eef

- Last Working -
Device: Buri v1.3 MOZ RIL
BuildID: 20131203040236
Gaia: 31808a29cfcffa584b6a88b4f1e515387f485a1b
Gecko: 8648aa476eef
Version: 28.0a1
Firmware Version: v1.2-device.cfg

- First Broken -
Device: Buri v1.3 MOZ RIL
BuildID: 20131204115608
Gaia: 324c467fc6b202fd09efe4b16cd83960fd2901eb
Gecko: 526e12792fc8
Version: 28.0a1
Firmware Version: v1.2-device.cfg

Push log: https://github.com/mozilla-b2g/gaia/compare/31808a29cfcffa584b6a88b4f1e515387f485a1b...324c467fc6b202fd09efe4b16cd83960fd2901eb
EJ will help check it.
Assignee: nobody → ejchen
Flags: needinfo?(arthur.chen)
Hi Matthew, 

I flashed from QA tool and tried to check the syndrome, but mozActivity works well on my side without any error. (I can click 'x' and Settings app would exit successfully.)

<Device Info on v1.4>

Gaia      961f7d4d51065cbe02e0546582817cddd4490f85
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/4c787a97ec6e
BuildID   20140420160201
Version   30.0a2
ro.build.version.incremental=324
ro.build.date=Thu Dec 19 14:04:55 CST 2013
Shallow Flash Done!
=================
Flash Information
=================
Your Target Build: PVT.v140.hamachi
URL:  https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-aurora-hamachi-eng/latest/
ENG Ver: true
Flash: Gaia, Gecko,


<Device Info on master>
Gaia      eb97461e75cd44d20967bc410b5653dff031ef5a
Gecko     https://hg.mozilla.org/mozilla-central/rev/28dc0100f9b0
BuildID   20140420160203
Version   31.0a1
ro.build.version.incremental=324
ro.build.date=Thu Dec 19 14:04:55 CST 2013
Shallow Flash Done!
=================
Flash Information
=================
Your Target Build: PVT.master.hamachi
URL:  https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-central-hamachi-eng/latest/
ENG Ver: true
Flash: Gaia, Gecko,

If I miss some critical steps or anything please let me know !! Any feedback is welcome, by the way.

Thanks !! :)
Flags: needinfo?(mvaughan)
Keywords: qawanted
While I noticed that on master, there is no `close.png` (BB got refactored 10 days ago to make this UI broken) so that we can't see the `x` button.

I would fix the image problem, but I have to make sure is there any functionality broken as this bug reported.
I tested again on hamachi with QA tool and they all WORK WELL:

<< v1.4 >>
Gaia      00279fff6ec4d48ce9c9469cd59d9219bb711f73
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/c180c22a7e2e
BuildID   20140422160203
Version   30.0a2
ro.build.version.incremental=324
ro.build.date=Thu Dec 19 14:04:55 CST 2013
Shallow Flash Done!
=================
Flash Information
=================
Your Target Build: PVT.v140.hamachi
URL:  https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-aurora-hamachi-eng/latest/
ENG Ver: true
Flash: Gaia, Gecko,

<< master >>
Gaia      0a4d2dea25a7162ee43db3a0db817798b70e7521
Gecko     https://hg.mozilla.org/mozilla-central/rev/1ab07aa4d004
BuildID   20140422160202
Version   31.0a1
ro.build.version.incremental=324
ro.build.date=Thu Dec 19 14:04:55 CST 2013
Shallow Flash Done!
=================
Flash Information
=================
Your Target Build: PVT.master.hamachi
URL:  https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-central-hamachi-eng/latest/
ENG Ver: true
Flash: Gaia, Gecko,

If there is no QA providing more useful or related information, based on my testings, I would resolve this bug as invalid and open another bug focusing to fix svg icon problem I talked about at comment #13.

thx

Comment 15

5 years ago
Hi All,
PLease check this code in settings.js, maybe this shouldn't return.
  if (this._currentActivity !== null &&
       (hash === '#home' ||
         (hash === '#root' && Settings._currentActivitySection !== 'root'))) {
     Settings.finishActivityRequest();
     return;
   }
EJ - I'm pretty sure this is reproducible if there's a window here. I'll have someone double check again though.

Comment 17

5 years ago
(In reply to EJ Chen [:eragonj][:小龍哥] from comment #12)
> Hi Matthew, 
> 
> I flashed from QA tool and tried to check the syndrome, but mozActivity
> works well on my side without any error. (I can click 'x' and Settings app
> would exit successfully.)
> 
> If I miss some critical steps or anything please let me know !! Any feedback
> is welcome, by the way.
> 
> Thanks !! :)

Hello EJ,

So after disabling and then re-enabling wifi in the notification pull down, the WiFi menu in the Settings app will appear automatically. When this happens, the issue in 1.4 where pressing the 'X' button (or blank area where the 'X' would be in Master) takes the user back to a blank Homescreen does not occur. (I outlined this in comment 4)

Instead, after re-enabling wifi, you need to tap the Settings button to manually launch into the WiFi menu. Then once you tap the 'X' button, or blank area in Master, you will be taken back to a blank Homescreen.

In 1.3, the 'X' button will not do anything for me on the first tap, regardless of how the WiFi menu opens. The second tap will successfully exit to the Settings menu for me.

I have attached a video showing the issue for 1.4. The same occurs in Master... the only difference is that the Homescreen is dimmed compared to 1.4, where it is not.

I hope this helps!
Flags: needinfo?(mvaughan)

Updated

5 years ago
Keywords: qawanted
(In reply to Matthew Vaughan from comment #17)
> I have attached a video showing the issue for 1.4. The same occurs in
> Master... the only difference is that the Homescreen is dimmed compared to
> 1.4, where it is not.
> 
> I hope this helps!

Thanks Matt, I found the missing step when testing here on my side according to your video. (We have to tap the settings button first !!)

I would check deeper about the root cause of this bug ! 

Big thankssss
Posted file patch on master (obsolete) —
Arthur, can you give me some feedbacks for this patch !? 

thx :)
Attachment #8411696 - Flags: feedback?(arthur.chen)
Posted file patch on v1.4 (obsolete) —
Basically this patch is the same with master patch without css change.
Attachment #8411706 - Flags: feedback?(arthur.chen)
Comment on attachment 8411696 [details]
patch on master

Per the offline discussion, please create a new type of web activity called "configure_inline" for the fake inline activity.
Attachment #8411696 - Flags: feedback?(arthur.chen)
Attachment #8411706 - Flags: feedback?(arthur.chen)
Comment on attachment 8411696 [details]
patch on master

Arthur, 

I just added some tests for this patch and I would make a new 1.4 patch because there are some conflicts.

If this patch is ok to you, I would start to make a v1.4 patch.

Thanks !
Attachment #8411696 - Flags: review?(arthur.chen)
Comment on attachment 8411706 [details]
patch on v1.4

Yeah,

added v1.4 specific patch already ! Hope you would like it , Arthur :)
Attachment #8411706 - Flags: review?(arthur.chen)
Comment on attachment 8411696 [details]
patch on master

Thanks for the patch. The code looks good to me. I left some comments regarding unit tests. Please check it. Please also request reviews from owners of other apps.
Attachment #8411696 - Flags: review?(arthur.chen)
Attachment #8411706 - Flags: review?(arthur.chen)
Thanks Arthur, I would r? you again !!
Comment on attachment 8411696 [details]
patch on master

Hi Alive & Julien & Arthur,

This patch is going to fix the problem which we handle different inline activity & window disposition at the same time. In the future, when AMD are ready, settings app would officially support inline activity and will refactor the change here.

Can you guys help me review your own related parts on each app !? Thanks :)
Attachment #8411696 - Flags: review?(felash)
Attachment #8411696 - Flags: review?(arthur.chen)
Attachment #8411696 - Flags: review?(alive)
Comment on attachment 8411147 [details]
Video of blank screen issue in 1.4

Hi Julien & Arthur,

This is v1.4 specific change, please kindly review this part also !

Thanks :)
Attachment #8411147 - Flags: review?(felash)
Attachment #8411147 - Flags: review?(arthur.chen)
Attachment #8411147 - Flags: review?(felash)
Attachment #8411147 - Flags: review?(arthur.chen)
Comment on attachment 8411706 [details]
patch on v1.4

Sorry to put you guys on the wrong link xD
Attachment #8411706 - Flags: review?(felash)
Attachment #8411706 - Flags: review?(arthur.chen)
Comment on attachment 8411706 [details]
patch on v1.4

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 
[User impact] if declined: Users will get the blank homescreen by following STR.
[Testing completed]: yes ! added on master & v1.4
[Risk to taking this patch] (and alternatives if risky): Normal. Currently there are three apps (sms, browser and system[quick_settings]) would interact with settings app by this method.
[String changes made]: no
Attachment #8411706 - Flags: approval-gaia-v1.4?
I am against that we have a "configure" and "configure_inline", but it's not really inline, activity at the same time. This name is exported to the web, please name it carefully.
Suggestion: still use config but change the disposition to inline when inline activity is really supported by settings app.
This is not regarding the support/not support of inline activity in settings app. The reason of proposing two different activities is that there are actually two different use cases. We have to allow apps to choose the one that fits their work flows. For example, when wifi panel is invoked from the utility tray, it should be invoked using window disposition. In another use case the message settings should be invoked using inline activity.
Flags: needinfo?(alive)
(In reply to Arthur Chen [:arthurcc] from comment #31)
> This is not regarding the support/not support of inline activity in settings
> app. The reason of proposing two different activities is that there are
> actually two different use cases. We have to allow apps to choose the one
> that fits their work flows. For example, when wifi panel is invoked from the
> utility tray, it should be invoked using window disposition. In another use
> case the message settings should be invoked using inline activity.
                                                    ^^^^^^^^^^^^^^^
This is just confusing since you are "not really inline".
What's the "use case"? Is it UX spec-ed or performance requirement?
Flags: needinfo?(alive)
I can't find the spec, but one of the request is as bug 942140. And bug 924409 is another example. I agree the workaround we used now is not a real inline activity. However, inline activity is going to be supported in v2.0, it is better to use the right term for it now.
Whiteboard: [ETA:5/9]
Target Milestone: --- → 2.0 S1 (9may)
(In reply to Alive Kuo [:alive][NEEDINFO!][OOO 4/30 - 5/4] from comment #32)
> This is just confusing since you are "not really inline".
> What's the "use case"? Is it UX spec-ed or performance requirement?

Alive,

you can try this behavior on sms apps (click on the three-dots icon to and click `settings` on the dialog) and on browser app (master) by trying to accessing a webpage without wifi, you will see a button which you can click to open the settings app. 

From the manifest, they are all using window disposition but used like inline activity. (When you leave settings, you will be taken back to original app) We all know this is not the a good idea to make one more path in manifest, but this would make more senses for developers to know what's going on behind the magic. 

And also, currently this is a temporary solution and will be changed back to use real inline activity when we finish our refactor works in Settings app. 

Any ideas or concerns are welcome and maybe we can discuss offline if possible ! 

Thanks Alive :)
Flags: needinfo?(alive)
Comment on attachment 8411696 [details]
patch on master

The SMS part looks simple enough, but I couldn't try the patch on latest master to confirm because this needs a rebase.
Comment on attachment 8411706 [details]
patch on v1.4

r=me for the patch for v1.4, works fine.

The only thing you could do to completely emulate an inline activity is to move back to the previous panel (if it was launched) or the main panel (if it wasn't) (or close the app) when the user presses the cross.
Attachment #8411706 - Flags: review?(felash) → review+
(In reply to Julien Wajsberg [:julienw] (away until 5th May) from comment #36)
> Comment on attachment 8411706 [details]
> patch on v1.4
> 
> r=me for the patch for v1.4, works fine.
> 
> The only thing you could do to completely emulate an inline activity is to
> move back to the previous panel (if it was launched) or the main panel (if
> it wasn't) (or close the app) when the user presses the cross.

But why don't you use a real inline activity for this?
Julien said what I want to say.
We could do some workaround in system to prevent there's no activity caller is present. In quick settings case the activity caller is system app but we cannot display system app again so in AppWindowManager we could invoke HomescreenLauncher.getHomescreen().open() for this case.

I can take this bug if you'd like to.
Flags: needinfo?(alive)
After discussed with Alive, I would provide another patch which would fix System bug also. I would update the patch later when it is ready !
Posted file patch on master
Alive, can you help me check this patch is ok or not ? I have tested it on my side and it does fix the bug. Just want to make sure I am on the right direction and any feedback is welcome :)
Attachment #8411696 - Attachment is obsolete: true
Attachment #8411696 - Flags: review?(felash)
Attachment #8411696 - Flags: review?(arthur.chen)
Attachment #8417221 - Flags: feedback?(alive)
Comment on attachment 8417221 [details] [review]
patch on master

Please fix as offline discussion
Attachment #8417221 - Flags: feedback?(alive)
Comment on attachment 8417221 [details] [review]
patch on master

@Alive, you would definitely love this patch. 

What do you think about this change !? I think this one is more elegant than previous one. xD
Flags: needinfo?(alive)
(In reply to EJ Chen [:eragonj][:小龍哥] from comment #42)
> Comment on attachment 8417221 [details] [review]
> patch on master
> 
> @Alive, you would definitely love this patch. 
> 
> What do you think about this change !? I think this one is more elegant than
> previous one. xD

Alive, based on our offline discussions, I made a change that we can just detect config.parentApp to make sure the caller is right. I also added a test case for it, can you help me take a look !? If this one is ok for you, I would start to make another 1.4 patch ! Thxx a lot !!
Whiteboard: [ETA:5/9] → [ETA:5/9][p=2]
++++++
Flags: needinfo?(alive)
Comment on attachment 8411706 [details]
patch on v1.4

Clear the request as now we patch the system app.
Attachment #8411706 - Flags: review?(arthur.chen)
Posted file patch on v1.4
Attachment #8411706 - Attachment is obsolete: true
Attachment #8411706 - Flags: approval-gaia-v1.4?
Comment on attachment 8417221 [details] [review]
patch on master

Alive, I just added tests for this patch and tested on the device.

Can you help me review the patch ? Thanks !!
Attachment #8417221 - Flags: review?(alive)
Comment on attachment 8417896 [details] [review]
patch on v1.4

Alive, I just added tests for this patch and tested on the device.

Can you help me review the patch ? Thanks !!
Attachment #8417896 - Flags: review?(alive)
Attachment #8417221 - Flags: review?(alive) → review+
Comment on attachment 8417896 [details] [review]
patch on v1.4

+++
Attachment #8417896 - Flags: review?(alive) → review+
Comment on attachment 8417896 [details] [review]
patch on v1.4

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: users would see transparent homescreen when exiting settings app
[Testing completed]: yes, I added all needed tests for this patch already.
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: no
Attachment #8417896 - Flags: approval-gaia-v1.4?
EJ

Is this a regression from 1.3?
Flags: needinfo?(ejchen)
(In reply to Preeti Raghunath(:Preeti) from comment #51)
> EJ
> 
> Is this a regression from 1.3?

Preeti, I didn't test on v1.3 but based on QA's comment, I think it may not be a regression from v1.3.

(In reply to Matthew Vaughan from comment #17)
> In 1.3, the 'X' button will not do anything for me on the first tap,
> regardless of how the WiFi menu opens. The second tap will successfully exit
> to the Settings menu for me.
Flags: needinfo?(ejchen)
(In reply to EJ Chen [:eragonj][:小龍哥] from comment #52)
> (In reply to Preeti Raghunath(:Preeti) from comment #51)
> > EJ
> > 
> > Is this a regression from 1.3?
> 
> Preeti, I didn't test on v1.3 but based on QA's comment, I think it may not
> be a regression from v1.3.
> 
> (In reply to Matthew Vaughan from comment #17)
> > In 1.3, the 'X' button will not do anything for me on the first tap,
> > regardless of how the WiFi menu opens. The second tap will successfully exit
> > to the Settings menu for me.

QA's testing concluded that this is a regression because the behavior of the bug got worse between 1.3 & 1.4. In 1.3, the X button failed to work once on a click & then worked on a second click. In 1.4, the bug got worse to show an empty homescreen problem happening as well.
Comment on attachment 8417896 [details] [review]
patch on v1.4

1.4+ blockers automatically get approval, so you don't need an approval-gaia-v1.4 here.
Attachment #8417896 - Flags: approval-gaia-v1.4?
(In reply to EJ Chen [:eragonj][:小龍哥] from comment #52)
> (In reply to Preeti Raghunath(:Preeti) from comment #51)
> > EJ
> > 
> > Is this a regression from 1.3?
> 
> Preeti, I didn't test on v1.3 but based on QA's comment, I think it may not
> be a regression from v1.3.
> 
> (In reply to Matthew Vaughan from comment #17)
> > In 1.3, the 'X' button will not do anything for me on the first tap,
> > regardless of how the WiFi menu opens. The second tap will successfully exit
> > to the Settings menu for me.

Thanks EJ. This is a 1.4 blocker and the gaia approval is not needed here.
Thanks, Jason & Preeti to clarify this. I would start to merge patches into our codebase !
Thanks all, patches got merged into :

Gaia/master : 5d92a1526f9a441bb875911331134275a06d6c60
Gaia/v1.4 : 4ce973ef0732b0d52cb043210db598aa176b2ce9

:)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.