Last Comment Bug 994638 - Let developer contact user/reply to user review
: Let developer contact user/reply to user review
Status: RESOLVED WONTFIX
[ux][ui][design][marketplace-transition]
:
Product: Marketplace
Classification: Server Software
Component: Consumer Pages (show other bugs)
: 2014-Q2
: All All
P5 enhancement with 10 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 968997 1044699 1072282 1081032 1103618 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-10 05:50 PDT by Raniere Silva
Modified: 2016-03-31 13:53 PDT (History)
28 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
2014-10-10-dev_whiteboard.pdf (126.52 KB, application/pdf)
2014-10-09 16:14 PDT, dihaynes77
no flags Details
Report Abuse - UI flow (current) (365.05 KB, image/png)
2014-10-14 22:22 PDT, Bram Pitoyo [:bram]
no flags Details
Steps one and two - drawings (845.44 KB, image/jpeg)
2014-10-15 12:25 PDT, dihaynes77
no flags Details
Step one A drawing (845.44 KB, image/jpeg)
2014-10-15 12:29 PDT, dihaynes77
no flags Details
step one b drawing (925.40 KB, image/jpeg)
2014-10-15 12:31 PDT, dihaynes77
no flags Details
step two c (947.23 KB, image/jpeg)
2014-10-15 12:35 PDT, dihaynes77
no flags Details

Description User image Raniere Silva 2014-04-10 05:50:34 PDT
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140409030203

Steps to reproduce:

1. Go to "App Review" page of one of your apps.
2. Find the new review/comment with a bug report.
3. Click on "Report" link at the end of review/comment.
4. Select "Bug Report".


Actual results:

The "Report" link disappears.


Expected results:

Open a dialog window to write a message for reviewer requesting more information about the bug.
Comment 1 User image Wil Clouser [:clouserw] 2014-04-16 15:41:53 PDT
Can you be more specific about the STR?  I think you might be talking about the reviewer tools, but I can't tell.  I'm not sure what the "App Review" page is, and I don't see anything with bug report links.
Comment 2 User image Andrew Williamson [:eviljeff] 2014-04-17 04:18:12 PDT
I strongly suspect the reporter is talking about the front end 'Reviews' page (i.e. user reviews).  With that assumption in mind, I believe he/she is confusing the 'report' link - which flags it to the app review team - with a reply facility to ask the user for more details on the bug.
Comment 3 User image Raniere Silva 2014-04-17 07:00:55 PDT
Yes, I'm talking about the front end "Reviews" page/user reviews (e.g. https://marketplace.firefox.com/app/my-app-name/ratings).

Sorry about the confusing. I want a "reply facility to ask the user for more details on the bug".
Comment 4 User image Daniele "Mte90" Scasciafratte 2014-05-08 06:49:05 PDT
Duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=968997
Comment 5 User image Andrew Williamson [:eviljeff] 2014-05-08 06:54:30 PDT
*** Bug 968997 has been marked as a duplicate of this bug. ***
Comment 6 User image Abid Aboobaker 2014-05-23 02:48:48 PDT
Can I fix this?
Comment 7 User image Mike Hoye [:mhoye] 2014-05-23 07:12:45 PDT
Abid: I think so! Let's just make sure.

Bram, are you working on this bug, or would you like to mentor Abid through the process?
Comment 8 User image Bram Pitoyo [:bram] 2014-05-26 22:35:06 PDT
Thanks for your interest! Yep. I’ll be the mentor of this bug.

The minimum viable actions that should happen are:
* User taps on “Report”
* User taps on “Misplaced bug report or support request”
* The modal window disappear. A new modal window appears to take its place. It will look similar to the “Report Abuse” interface
* Ideally, this window should not only give developers a text box to type a reply in, but also display the user review. By showing the original review, the developer can see the context and write a better reply.
* Make sure that the design fits within a 320x480 interface with a keyboard overlay underneath

You can start prototyping ideas on paper, and then uploading the scans here for review. Displaying user reply without crowding out the space designed for text box is an interesting problem to solve.

Sounds good?

Thanks for contributing!
Comment 9 User image Andrew Williamson [:eviljeff] 2014-06-23 05:40:30 PDT
dupe of bug 847947?
Comment 10 User image Niccolò "nicokant" Cantù [: nicokant] 2014-06-26 10:34:09 PDT
are there some news about this bug? it's very important to get more accurate details from users! thanks :)
Comment 11 User image Bram Pitoyo [:bram] 2014-06-26 23:18:03 PDT
(In reply to Andrew Williamson [:eviljeff] from comment #9)
> dupe of bug 847947?

Bug 847947 is a server operations bug. Is it possible that you’re posting the wrong bug here?


(In reply to niccolocantu94 from comment #10)
> are there some news about this bug? it's very important to get more accurate
> details from users! thanks :)

Abid Aboobaker is proposing to work on it, but we haven’t heard from him lately. Are you possibly interested in collaborating or helping out?
Comment 12 User image Andrew Williamson [:eviljeff] 2014-06-27 05:07:15 PDT
(In reply to Bram Pitoyo [:bram] from comment #11)
> (In reply to Andrew Williamson [:eviljeff] from comment #9)
> > dupe of bug 847947?
> 
> Bug 847947 is a server operations bug. Is it possible that you’re posting
> the wrong bug here?

sorry I meant bug 874947 - I suppose its not an exact dupe but is covering the same issue, that users are writing reviews rather than contacting the developer with bug reports.
Comment 13 User image Rabimba 2014-07-16 07:15:01 PDT
@Bram - Is there any new development on this bug/feature or is it still on whiteboard practice stage? I am in need of a speedy fix for this. Would be willing to contribute if it's ok.
Comment 14 User image Bram Pitoyo [:bram] 2014-07-17 15:08:32 PDT
(In reply to karanjai.moz from comment #13)
> @Bram - Is there any new development on this bug/feature or is it still on
> whiteboard practice stage? I am in need of a speedy fix for this. Would be
> willing to contribute if it's ok.

If you’re willing to contribute, that’d be great! Please see comment #8 for a general guidance of how this bug should be handled. Post your prototypes here, and I will be available to give you feedback.
Comment 15 User image Rabimba 2014-07-18 06:26:09 PDT
(In reply to Bram Pitoyo [:bram] from comment #14)
> (In reply to karanjai.moz from comment #13)
> > @Bram - Is there any new development on this bug/feature or is it still on
> > whiteboard practice stage? I am in need of a speedy fix for this. Would be
> > willing to contribute if it's ok.
> 
> If you’re willing to contribute, that’d be great! Please see comment #8 for
> a general guidance of how this bug should be handled. Post your prototypes
> here, and I will be available to give you feedback.

Yup I saw that before commenting :)
So to start you just need a wireframe and then I can start tinkering with the code, right? 
Have a few more doubts, do you want to continue the discussion here or there any irc or anyplace else I should visit
Comment 16 User image Bram Pitoyo [:bram] 2014-07-20 14:51:44 PDT
That’s right. It’s important that we get a wireframe that shows the flow our customers will go through to submit a report. When we know how it will work, then we can go ahead with the code implementation. And if you have any detailed question, ask me via email to avoid clogging the bug.
Comment 17 User image Wil Clouser [:clouserw] 2014-07-30 10:28:21 PDT
*** Bug 1044699 has been marked as a duplicate of this bug. ***
Comment 18 User image Flaburgan 2014-08-22 03:28:24 PDT
I just have the problem on my application https://marketplace.firefox.com/app/diaspora

A user is complaining about a missing feature which is implemented but I guess he didn't find it. I'd like to answer that the feature is not missing because that could confuse other people looking at reviews.

It looks like the marketplace doesn't allow to anwswer to reviews at the moment.
Comment 19 User image Mathieu Pillard [:mat] 2014-09-24 06:23:10 PDT
*** Bug 1072282 has been marked as a duplicate of this bug. ***
Comment 20 User image Nazar Mokrynskyi 2014-09-24 09:25:44 PDT
Any updates? Really need this.
Comment 21 User image dihaynes77 2014-09-29 14:50:59 PDT
Hi, Bram - Are you only looking for a volunteer to do wire framing/user flow or will the person who picks this up also code the fix?
Comment 22 User image Mike Hoye [:mhoye] 2014-10-08 11:21:34 PDT
It looks like we've had a few people say they're interested in giving it a shot, but  no patches yet.

OK, everyone who's CC'd  on this: we've got a good sketch of the fix listed in comment 8, and a couple of people interested: show us what you've got so far, let's get this one over the line.
Comment 23 User image dihaynes77 2014-10-09 16:04:07 PDT
(In reply to Mike Hoye [:mhoye] from comment #22)
> It looks like we've had a few people say they're interested in giving it a
> shot, but  no patches yet.
> 
> OK, everyone who's CC'd  on this: we've got a good sketch of the fix listed
> in comment 8, and a couple of people interested: show us what you've got so
> far, let's get this one over the line.

Hi Mike and Brad - I've attached what I have by way of a wire frame for a UX solution. I noted my understanding of the ask and suggestions for slight alterations. The colors are only there to show contrasts/placement in the mobile environment. Also, I made notes related to mobile and web versions. My thought process is in HTML5 functionality so I would welcome any guidance on how Javascript might inhibit the proposal. I am hoping to work on this for my Ascend Project bug.
Comment 24 User image dihaynes77 2014-10-09 16:14:18 PDT
Created attachment 8502861 [details]
2014-10-10-dev_whiteboard.pdf

UX wire frame suggestions. I considered the size restrictions of this as a mobile solution, but it is not drawn to scale. These are some early ideas and do not contain any visual design elements. I look forward to feedback!
Comment 25 User image dihaynes77 2014-10-10 14:23:29 PDT
Hi Bram,
Would you mind uploading a screenshot of what the user currently sees when they are looking a review (or reviews)from within their account? Also, if there is a 'Report Abuse' workflow that I should see for comparison, that would be great, too. I uploaded a very early wire frame and suggestions that I will be improving over the weekend. 
Thanks in advance.
Comment 26 User image dihaynes77 2014-10-10 14:28:16 PDT
(In reply to Mike Hoye [:mhoye] from comment #22)
> It looks like we've had a few people say they're interested in giving it a
> shot, but  no patches yet.
> 
> OK, everyone who's CC'd  on this: we've got a good sketch of the fix listed
> in comment 8, and a couple of people interested: show us what you've got so
> far, let's get this one over the line.

Hi Mike - Greetings from Ascend Portland. I uploaded some early wire frame suggestions but didn't know if that would be considered a "patch" since it's not code. Should I upload the same thing today(Friday) or Monday as a patch or leave it as an image?
Comment 27 User image dihaynes77 2014-10-14 14:46:08 PDT
(In reply to Bram Pitoyo [:bram] from comment #8)
> Thanks for your interest! Yep. I’ll be the mentor of this bug.
> 
> The minimum viable actions that should happen are:
> * User taps on “Report”
> * User taps on “Misplaced bug report or support request”
> * The modal window disappear. A new modal window appears to take its place.
> It will look similar to the “Report Abuse” interface
> * Ideally, this window should not only give developers a text box to type a
> reply in, but also display the user review. By showing the original review,
> the developer can see the context and write a better reply.
> * Make sure that the design fits within a 320x480 interface with a keyboard
> overlay underneath
> 
> You can start prototyping ideas on paper, and then uploading the scans here
> for review. Displaying user reply without crowding out the space designed
> for text box is an interesting problem to solve.
> 
> Sounds good?
> 
> Thanks for contributing!

Hi Bram,
What do you think of the screen shots so far? https://bugzilla.mozilla.org/attachment.cgi?id=8502861
Candida
Comment 28 User image Andy McKay [:andym] 2014-10-14 15:59:16 PDT
*** Bug 1081032 has been marked as a duplicate of this bug. ***
Comment 29 User image Bram Pitoyo [:bram] 2014-10-14 22:22:14 PDT
Created attachment 8505263 [details]
Report Abuse - UI flow (current)

(In reply to dihaynes77 from comment #25)
> Would you mind uploading a screenshot of what the user currently sees when
> they are looking a review (or reviews)from within their account? Also, if
> there is a 'Report Abuse' workflow that I should see for comparison, that
> would be great, too.

Hi Candida,

Thanks for your contribution to this bug!

The current flow for reporting misplaced bug is attached here.

To clarify, there’s only one screen that needs to be designed. It’s the screen that shows up after the developer selects “Misplaced bug report”.

Your first pass at a solution looks great.

Moving forward, I would suggest drawing a lot of interface sketches on paper, scanning or taking pictures of them, and uploading them here.

Paper sketches may look like this:
https://encrypted.google.com/search?tbm=isch&q=ui+sketch+paper

I like how you’ve captioned parts of your mockups to explain what each part does (e.g. “x’s do not autopopulate”, “this should scroll”). You should continue doing this on paper.

Start sketching on what this interface could look like on a Firefox OS phone with the keyboards open. We’re looking at a 480x320 screen of about 3.5 inches diagonally. That’s the first step.

The second step is to take the same sketch and think of what the same interface could look like when scaled up for tablets and desktop.

After the second step is done and all the files have been uploaded here, we can have a look at them and decide on the best option to explore further.

The options worth exploring further will then be refined to a prototype that’s less sketchy. But we’ll save this for later!

Does this plan sound good to you? Am I unclear with my instructions above? Let me know!
Comment 30 User image dihaynes77 2014-10-15 00:34:56 PDT
(In reply to Bram Pitoyo [:bram] from comment #29)
> Created attachment 8505263 [details]
> Report Abuse - UI flow (current)
> 
> (In reply to dihaynes77 from comment #25)
> > Would you mind uploading a screenshot of what the user currently sees when
> > they are looking a review (or reviews)from within their account? Also, if
> > there is a 'Report Abuse' workflow that I should see for comparison, that
> > would be great, too.
> 
> Hi Candida,
> 
> Thanks for your contribution to this bug!
> 
> The current flow for reporting misplaced bug is attached here.
> 
> To clarify, there’s only one screen that needs to be designed. It’s the
> screen that shows up after the developer selects “Misplaced bug report”.
> 
> Your first pass at a solution looks great.
> 
> Moving forward, I would suggest drawing a lot of interface sketches on
> paper, scanning or taking pictures of them, and uploading them here.
> 
> Paper sketches may look like this:
> https://encrypted.google.com/search?tbm=isch&q=ui+sketch+paper
> 
> I like how you’ve captioned parts of your mockups to explain what each part
> does (e.g. “x’s do not autopopulate”, “this should scroll”). You should
> continue doing this on paper.
> 
> Start sketching on what this interface could look like on a Firefox OS phone
> with the keyboards open. We’re looking at a 480x320 screen of about 3.5
> inches diagonally. That’s the first step.
> 
> The second step is to take the same sketch and think of what the same
> interface could look like when scaled up for tablets and desktop.
> 
> After the second step is done and all the files have been uploaded here, we
> can have a look at them and decide on the best option to explore further.
> 
> The options worth exploring further will then be refined to a prototype
> that’s less sketchy. But we’ll save this for later!
> 
> Does this plan sound good to you? Am I unclear with my instructions above?
> Let me know!

Thanks for writing this! I appreciate the screen shots, too - they help me think about flow with the current UI. I can send some sketches later today(Wednesday).
Comment 31 User image dihaynes77 2014-10-15 12:25:37 PDT
Created attachment 8505676 [details]
Steps one and two - drawings

one of three. feel free to request more.
Comment 32 User image dihaynes77 2014-10-15 12:29:31 PDT
Created attachment 8505680 [details]
Step one A drawing

two of three
Comment 33 User image dihaynes77 2014-10-15 12:31:37 PDT
Created attachment 8505682 [details]
step one b drawing

two of three
Comment 34 User image dihaynes77 2014-10-15 12:35:06 PDT
Created attachment 8505683 [details]
step two c

three of 3
it's the same as "Steps one and two - drawings" obsoleted it bc my wording made things confusing.
Comment 35 User image dihaynes77 2014-10-16 15:16:38 PDT
(In reply to dihaynes77 from comment #30)
> (In reply to Bram Pitoyo [:bram] from comment #29)
> > Created attachment 8505263 [details]
> > Report Abuse - UI flow (current)
> > 
> > (In reply to dihaynes77 from comment #25)
> > > Would you mind uploading a screenshot of what the user currently sees when
> > > they are looking a review (or reviews)from within their account? Also, if
> > > there is a 'Report Abuse' workflow that I should see for comparison, that
> > > would be great, too.
> > 
> > Hi Candida,
> > 
> > Thanks for your contribution to this bug!
> > 
> > The current flow for reporting misplaced bug is attached here.
> > 
> > To clarify, there’s only one screen that needs to be designed. It’s the
> > screen that shows up after the developer selects “Misplaced bug report”.
> > 
> > Your first pass at a solution looks great.
> > 
> > Moving forward, I would suggest drawing a lot of interface sketches on
> > paper, scanning or taking pictures of them, and uploading them here.
> > 
> > Paper sketches may look like this:
> > https://encrypted.google.com/search?tbm=isch&q=ui+sketch+paper
> > 
> > I like how you’ve captioned parts of your mockups to explain what each part
> > does (e.g. “x’s do not autopopulate”, “this should scroll”). You should
> > continue doing this on paper.
> > 
> > Start sketching on what this interface could look like on a Firefox OS phone
> > with the keyboards open. We’re looking at a 480x320 screen of about 3.5
> > inches diagonally. That’s the first step.
> > 
> > The second step is to take the same sketch and think of what the same
> > interface could look like when scaled up for tablets and desktop.
> > 
> > After the second step is done and all the files have been uploaded here, we
> > can have a look at them and decide on the best option to explore further.
> > 
> > The options worth exploring further will then be refined to a prototype
> > that’s less sketchy. But we’ll save this for later!
> > 
> > Does this plan sound good to you? Am I unclear with my instructions above?
> > Let me know!
> 
> Thanks for writing this! I appreciate the screen shots, too - they help me
> think about flow with the current UI. I can send some sketches later
> today(Wednesday).

I uploaded some drawings yesterday but wasn't sure how to ping you on here. Also, how would you feel about sketches that are digital but just lines (rectangles etc.) and text. Having gone through both processes and losing a bug at a different Mozilla project after submitting drawings, I am definitely more comfortable submitting sketches that way. For me, it's faster and feels less restrictive.

Thanks, and let me know what you think of the ideas in the drawings or of you want more information.
Comment 36 User image Bram Pitoyo [:bram] 2014-10-16 19:57:50 PDT
I don’t think having two separate actions is necessary here. We only need the ability for developers to respond to a user’s comment. Mozilla doesn’t need to be notified of any bug.

So, having one button is fine. But the challenge here is, on the phone, screen real estate is limited. So how can we show *both* the user’s comment and the text box?

On tablet and desktop, laying the user comment and text box side by side looks good. Your solution here works out.

So the next step is to sketch the best way to utilise that small space on the phone. We’re working on a 320x480 screen of around 3.5" diagonal dimension, nearly half of it covered by the keyboard.

As far as submission format is concerned, use anything you feel comfortable submitting! If coming up with a lot of layout is faster to do with pen and paper, do that. If it’s faster on the computer, do that.

Your task and deliverable: explore enough layout variations on mobile, tablet and desktop sizes, and post them here. Feel free to combine them in one image if it makes your job easier.

I would suggest looking at:
* How we implement our review system today (go to any app on the Marketplace and select “Write a Review”)
* How the review system might look in the future (http://brampitoyo.github.io/marketplace-style-guides/app-details-review-write.html – it’s not yet final, but take it as an inspiration)
Comment 37 User image dihaynes77 2014-10-17 14:46:00 PDT
The inspiration is perfect and the deliverables are clear. Thank you! It's the last day of the Ascend Project so I will sketch and combine these this this weekend. Thanks!

(In reply to Bram Pitoyo [:bram] from comment #36)
> I don’t think having two separate actions is necessary here. We only need
> the ability for developers to respond to a user’s comment. Mozilla doesn’t
> need to be notified of any bug.
> 
> So, having one button is fine. But the challenge here is, on the phone,
> screen real estate is limited. So how can we show *both* the user’s comment
> and the text box?
> 
> On tablet and desktop, laying the user comment and text box side by side
> looks good. Your solution here works out.
> 
> So the next step is to sketch the best way to utilise that small space on
> the phone. We’re working on a 320x480 screen of around 3.5" diagonal
> dimension, nearly half of it covered by the keyboard.
> 
> As far as submission format is concerned, use anything you feel comfortable
> submitting! If coming up with a lot of layout is faster to do with pen and
> paper, do that. If it’s faster on the computer, do that.
> 
> Your task and deliverable: explore enough layout variations on mobile,
> tablet and desktop sizes, and post them here. Feel free to combine them in
> one image if it makes your job easier.
> 
> I would suggest looking at:
> * How we implement our review system today (go to any app on the Marketplace
> and select “Write a Review”)
> * How the review system might look in the future
> (http://brampitoyo.github.io/marketplace-style-guides/app-details-review-
> write.html – it’s not yet final, but take it as an inspiration)

I like this! I am at crunch time as the Ascend Project (open source training) ends today, but I can jot some things down this weekend.
Comment 38 User image Andy McKay [:andym] 2014-11-25 14:01:28 PST
*** Bug 1103618 has been marked as a duplicate of this bug. ***
Comment 39 User image David Durst [:ddurst] 2015-03-05 10:45:19 PST
Any update on this?
Comment 40 User image Ram Dayal Vaishnav [:ramd] 2015-07-16 15:07:55 PDT
Looks quite difficult bug for newbies, marking it as [good second bug] for now.
Comment 41 User image Andrew Williamson [:eviljeff] 2015-07-17 03:59:56 PDT
note, it may be a good first/second UX design bug, but the actual implementation would be considerably more complicated.
Comment 42 User image Kevin Ngo [:ngoke] 2015-07-17 12:35:01 PDT
Marking this for wontfix, we'll never get around to implementing this with our current resources.
Comment 43 User image Flaburgan 2015-07-18 02:54:22 PDT
Wow seriously? I didn't check the code of the app but to me it looks only like to add a text field "ownerAnswer" on the "comment" table. If you (or moco) is not going to fix it, at least let it open for volunteers to grab it.
Comment 44 User image Anthony Ricaud (:rik) 2015-07-18 05:27:16 PDT
That's the great thing about open source, "resources" can come any time to try and fix this.

Kevin: Unless you think this bug shouldn't be fixed, I suggest keeping it open.
Comment 45 User image Kevin Ngo [:ngoke] 2015-07-18 13:28:03 PDT
Yeah, add the field to the model, write a migration, write a DRF view and serializer, tests, frontend design + UI for submitting and displaying it, frontend tests. And we might be rewriting the frontend soon. Grab it if you like.
Comment 46 User image Kevin Ngo [:ngoke] 2015-07-18 13:31:26 PDT
Oh, and more notes. Permission checks from top to bottom that the user is the developer of the app.

Note You need to log in before you can comment on or make changes to this bug.