Closed Bug 994681 Opened 6 years ago Closed 5 years ago

[video] White outline offset to play button background

Categories

(Firefox OS Graveyard :: Gaia::Video, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: amylee, Assigned: pivanov)

References

Details

(Whiteboard: visual design, [fxos:media], ux-most-wanted)

Attachments

(7 files)

Attached image play_video.png
In Gallery when you select a video, the large play button background isn't aligned with the white outline. See attached screenshot.
No longer blocks: 971444
Whiteboard: ux-tracking, visual design, jian [fxos:media] → visual design, [fxos:media], ux-most-wanted
Blocks: 994991
Can someone work on this one? It's been an eyesore for a while, I would love to see this fixed! Thanks
Blocks: 1069288
Assignee: nobody → pivanov
Hey Amy,
can you provide me the play button icon with size 100x100 or 104x104 pixels for @1x version and based on your choice all other versions @1.5x, @2x, @2.25x etc.

an I also need the color and opacity/transparency of this image: https://github.com/mozilla-b2g/gaia/blob/master/apps/gallery/style/images/video_play_normal.png

Thanks :)
Attached file Play_Icon.zip
Hi Pavel, 

Here are the png's for the play icon. As for the background circle colour:

Blue Circle: #0d6c80 opacity: 80%
Grey Circle: #000000 opacity: 65% 

Let me know if you need anything else. Thanks
Attached file patch for Gaia/master
Attachment #8509308 - Flags: ui-review?(amlee)
(In reply to Pavel Ivanov [:ivanovpavel] from comment #5)
> Created attachment 8509308 [details] [review]
> patch for Gaia/master

Hi Pavel, 

Can you send me a screen shot of the video screen (also in the blue pressed stat). Thanks
Flags: needinfo?(pivanov)
Attached image Shot 1
Flags: needinfo?(pivanov)
Attached image Shot 2
Flags: needinfo?(amlee)
(In reply to Pavel Ivanov [:ivanovpavel] from comment #8)
> Created attachment 8510147 [details]
> Shot 2

Hi Pavel, 

The background circle should be INSIDE the white circle boarder. Thanks!
Flags: needinfo?(amlee)
Comment on attachment 8509308 [details] [review]
patch for Gaia/master

Hi Pavel,
The background circle should be INSIDE the white circle boarder. Thanks!
Attachment #8509308 - Flags: ui-review?(amlee) → ui-review-
Attached image Shot 1 v2
Attached image Shot 2 v2
Attachment #8509308 - Flags: ui-review- → ui-review?(amlee)
Comment on attachment 8509308 [details] [review]
patch for Gaia/master

Looks good! Thanks Pavel
Attachment #8509308 - Flags: ui-review?(amlee) → ui-review+
Attachment #8509308 - Flags: review?(rnicoletti)
Comment on attachment 8509308 [details] [review]
patch for Gaia/master

Hi Pavel, the patch looks good to me, but since I am not a peer of the gallery app I think it's best if Punam also reviews. I'm setting the flag for her.
Attachment #8509308 - Flags: review?(rnicoletti)
Attachment #8509308 - Flags: review?(pdahiya)
Attachment #8509308 - Flags: review+
Thanks :)

Landing to master:
https://github.com/mozilla-b2g/gaia/commit/bbde027dac30c7e256e89540f9353566698dea22
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8509308 [details] [review]
patch for Gaia/master

Patch looks good, I assume it's tested by previous reviewers, few observations since we are no longer using images/video_play_normal.png, images/video_play_focus.png we should delete these files from gallery app.

Also, we are using play icon in camera app preview, we should check and get these changes updated in camera app video player css file.
Attachment #8509308 - Flags: review?(pdahiya) → review+
You need to log in before you can comment on or make changes to this bug.