Closed Bug 994691 Opened 10 years ago Closed 9 years ago

[Bluetooth] Confirmation icon too small and text should be center aligned

Categories

(Firefox OS Graveyard :: Gaia::Bluetooth, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: amylee, Assigned: pivanov)

References

Details

(Keywords: polish, Whiteboard: ux-most-wanted, visual design, [fxos:media], 2x-uxnom)

Attachments

(8 files, 1 obsolete file)

Attached image bluetooth.png
The bluetooth icon looks too small and the text between the hairlines should be centered.

Steps to reproduce:

1. Open music app
2. Select song to play
3. Select share
4. Select Bluetooth Transfer
No longer blocks: 965489
Whiteboard: ux-tracking, visual design, jian [fxos:media] → ux-most-wanted, visual design, [fxos:media]
Blocks: 994991
Blocks: 1069288
Assignee: nobody → pivanov
Component: Gaia::Camera → Gaia::Music
Component: Gaia::Music → Gaia::Bluetooth File Transfer
Summary: [Music] Bluetooth confirmation icon too small and text should be center aligned → [Bluetooth] Confirmation icon too small and text should be center aligned
Hey Amy can you provide the icon?
Flags: needinfo?(amlee)
Hi Pavel, 

I've attached an svg of the icon. Let me know if you need it in any other format. I've also attached a screen for placement. The icon and text should be vertically centered to the row. 

Thanks!
Flags: needinfo?(amlee)
Attached image Bluetooth_Screen.jpg
Screenshot for correct placement
Hey Amy,

can you give me the size of the icon?
Flags: needinfo?(amlee)
(In reply to Pavel Ivanov [:ivanovpavel][:pivanov] from comment #4)
> Hey Amy,
> 
> can you give me the size of the icon?

Hi Pavel, 

It's 10px x 21px
Flags: needinfo?(amlee)
Hey Amy ... are you sure that the size need to be 10x21 pixels? because current icon is 64x64 pixels and the real height of the Bluetooth Icon is ~24x46 pixels? and we need to make it bigger right?
Flags: needinfo?(amlee)
(In reply to Pavel Ivanov [:ivanovpavel][:pivanov] from comment #6)
> Hey Amy ... are you sure that the size need to be 10x21 pixels? because
> current icon is 64x64 pixels and the real height of the Bluetooth Icon is
> ~24x46 pixels? and we need to make it bigger right?

Hi Pavel, 

Apologies, the icon should be 22x46px based on a 320x480 screen.
Flags: needinfo?(amlee)
Whiteboard: ux-most-wanted, visual design, [fxos:media] → ux-most-wanted, visual design, [fxos:media], 2x-uxnom
Hey Amy,
if we use 22x46 pixels for the icon it will be the same size as is now. I think that you want bigger icon?
Flags: needinfo?(amlee)
(In reply to Pavel Ivanov [:ivanovpavel][:pivanov] from comment #8)
> Hey Amy,
> if we use 22x46 pixels for the icon it will be the same size as is now. I
> think that you want bigger icon?

Hi Pavel, 

I measured the icon as 22x46px on a 320x480 screen and on flame size it's 33x69.
Flags: needinfo?(amlee)
Whiteboard: ux-most-wanted, visual design, [fxos:media], 2x-uxnom → ux-most-wanted, visual design, [fxos:media], 2x-uxnom, polish
Keywords: polish
Whiteboard: ux-most-wanted, visual design, [fxos:media], 2x-uxnom, polish → ux-most-wanted, visual design, [fxos:media], 2x-uxnom
Attached image Shot from Device (obsolete) —
Hey Amy,

I just take a shot from my device. I think it works fine now. What do you think?
Flags: needinfo?(amlee)
(In reply to Pavel Ivanov [:ivanovpavel][:pivanov] from comment #10)
> Created attachment 8650648 [details]
> Shot from Device
> 
> Hey Amy,
> 
> I just take a shot from my device. I think it works fine now. What do you
> think?

Hi Pavel, 

It still looks too small. I attached a mock of how the icon should look in this bug. https://bug994691.bmoattachments.org/attachment.cgi?id=8516809

Thanks
Flags: needinfo?(amlee)
Attached image Shot from Device
What do you think?
Flags: needinfo?(amlee)
Comment on attachment 8650686 [details]
Shot from Device

Can you reduce the height by 2px so it's aligned to the top and bottom of the text height? Thanks!
Flags: needinfo?(amlee)
Attachment #8650648 - Attachment is obsolete: true
Attached image Shot from Device
Like this one?
(In reply to Pavel Ivanov [:ivanovpavel][:pivanov] from comment #14)
> Created attachment 8650701 [details]
> Shot from Device
> 
> Like this one?

Looks good. Thanks!
Attached file patch for Gaia/master
Attachment #8651140 - Flags: review?(shuang)
(In reply to Pavel Ivanov [:ivanovpavel][:pivanov] UX from comment #17)
> Created attachment 8651140 [details] [review]
> patch for Gaia/master

Opps, I'm not the right person to review this. Forward to Fred.
Attachment #8651140 - Flags: review?(shuang) → review?(gasolin)
review blocked by bug 1197735 since it make the UI not shown
Depends on: 1197735
Comment on attachment 8651140 [details] [review]
patch for Gaia/master

looks good to me, though I feel the BT icon is a bit longer at the bottom on flame
Attachment #8651140 - Flags: review?(gasolin) → review+
Attached image bticon.png
Thanks :)

Landed to master:
https://github.com/mozilla-b2g/gaia/commit/e69f2c86b931b723dd405115e33a1d02e6c5f5e6
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: