Converting multiple text styles into a table the styles are lost once in the table

NEW
Unassigned

Status

SeaMonkey
Composer
17 years ago
6 years ago

People

(Reporter: TucsonTester2, Unassigned)

Tracking

Trunk
All
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Halloween2011Bug])

(Reporter)

Description

17 years ago
Build:2001091003

Entering different text styles into a blank composer page and then converting 
them into a table you will see the text styles are gone except for text in the 
first cell of each row.

Reproducible:Everytime

Steps to reproduce:
1.Open a blank composer page and insert text (e.g.Italic text first)
2.Highlight the text and choose format>text style>italics or use the format 
toolbar buttons to change the text.  Make 2 hard returns and then discontinue 
text style from the format menu.
3.Repeat the above steps making the second line of text underline text and the 
third line of text bold and the final line just normal text.  Be sure to put 3 
words in each line of text in order to see the results.(e.g.Italic text 
first,Underline text second and so on)
4.Select all and from the composition toolbar click on the table icon and 
select space as seperator, ignore extra spaces and delete separator 
character,click OK.

Actual results:
The text is inserted into a table and in the first cell of each row the text 
receives whatever style was chosen but all remaining text in the other cells 
will convert to normal text.

Expected results:
I expected all text styles to carry over into all cells in the table.

I also tried typing one long line of bold text, inserted it into a table and 
not one word was bold not even the first word in the first cell.

Comment 1

17 years ago
Confirmed on build 2001091303.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
--> cmanske
Assignee: kin → cmanske

Comment 3

17 years ago
This is an unfortunate side effect of the efficient HTML Source-based design for 
this feature. We should switch to a DOM-based strategy in the future to make it
more flexible and smarter.
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 4

17 years ago
** I ran in to this type of case when using different colored text as well, I 
was using Windows 2000.  
   
If you enter some text lines having each line be a different color (i.e., 2-4 
lines). Highlight all the text and click on the table icon on the toolbar and 
select space as separator, ignore extra spaces and delete separator 
character, click OK.  The text is inserted into a table and in the first cell 
of each row the text receives whatever color was chosen but all remaining text 
in the other cells will convert to the default black text.

** use the same steps to reduce as below but instead of text styles use lines 
of different colors.  

Comment 5

16 years ago
*** Bug 107626 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
Assignee: cmanske → nobody
Status: ASSIGNED → NEW
QA Contact: sujay → composer
Target Milestone: Future → ---
This bug is being marked EXPIRED as it has seen no activity in a very long time.

If you think that the issue reported might still be relevant, please test with a recent release of SeaMonkey and if the problem persists feel free to re-open the report. Thank you.

http://www.seamonkey-project.org/
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → EXPIRED
Bulk reopening incorrectly expired bugs - no activity does not constitute no bug - these need proper checking.
Status: RESOLVED → REOPENED
Resolution: EXPIRED → ---
Status: REOPENED → UNCONFIRMED

Comment 8

6 years ago
Still here
Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111017 Firefox/10.0a1 SeaMonkey/2.7a1
Confirmed based on comment #8
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [Halloween2011Bug]
You need to log in before you can comment on or make changes to this bug.