[NATIVE-WIDGET] Combobox is wrong color

VERIFIED WONTFIX

Status

()

Core
Layout: Form Controls
P2
normal
VERIFIED WONTFIX
19 years ago
19 years ago

People

(Reporter: Niccolò Gallarati, Assigned: Kevin McCluskey (gone))

Tracking

Trunk
All
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
There are some graphics bug, I attach an image to explain 'em better.
Bugs descriptions:
1- the scroll bar disappears when window is resized less than half screen
(this bug is already submitted as #6075)
2- the vertical scroll bar become corrupted when window is resized less than
half screen (you can see it in the attached image)
3- the engine search selector (the combobox with the text "HotBot") background
is gray but it should be white
4- there are some words like "pixel" around the page (it may be not a bug)

workarounds:
1- check the window refresh code
2- refresh it when window is resized
3- change the combobox attributes
4- remove the test code

software:
mozilla 5.0 build 1999070308
os: windows 2000 beta 3 build 2031
graphics: nvidia riva tnt
(Reporter)

Comment 1

19 years ago
Created attachment 899 [details]
the browser window resized

Updated

19 years ago
Assignee: don → davidm
Component: Browser-General → XPApps
Priority: P3 → P2
Target Milestone: M12

Updated

19 years ago
Assignee: davidm → troy
Component: XPApps → Layout

Comment 2

19 years ago
reassign to layout

Updated

19 years ago
Summary: some graphic bugs when resizing browser window → Combobox is wrong color

Updated

19 years ago
Assignee: troy → kmcclusk
Component: Layout → HTML Form Controls

Comment 3

19 years ago
I don't see the scrollbar problems anymore, and so I think they have been fixed.
That's likely the case, because it took a month for the bug to get re-assigned
to layout

Comment 4

19 years ago
That leaves the remaining issue of the combobox being gray instead of white.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Summary: Combobox is wrong color → [NATIVE-WIDGET] Combobox is wrong color
Target Milestone: M12 → M15
(Assignee)

Comment 5

19 years ago
The combobox is grey only when native select's are used. It is white when in gfx
rendering mode. Marking as [NATIVE-WIDGET] issue an moving to M15. gfx selects
will be the default in M10.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

19 years ago
Fixed by enabling gfx rendered form elements as of Aug 19, 1999 4:00PM.

Will not fix for native widgets

Updated

19 years ago
Status: RESOLVED → VERIFIED
QA Contact: leger → phillip
Target Milestone: M15 → M10

Comment 7

19 years ago
phillip, please verify

Updated

19 years ago
Status: VERIFIED → REOPENED

Comment 8

19 years ago
this is really a WONTFIX. reopening...

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: FIXED → WONTFIX

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 9

19 years ago
verified
You need to log in before you can comment on or make changes to this bug.